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CASE TOOLS LAB 



WEEK – 1 (A) 
 
1.1 OBJECTIVE:  
 

Generate Use case Diagram for ATM System  

 

1.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  

 

1.3 DESCRIPTION:  

 
The purpose of use case diagram is to capture the dynamic aspect of a system. But this definition is too 

generic to describe the purpose. Because other four diagrams (activity, sequence, collaboration and State 

chart) are also having the same purpose. So we will look into some specific purpose which will 

distinguish it from other four diagrams. Use case diagrams are used to gather the requirements of a 

system including internal and external influences. These requirements are mostly design requirements. So 

when a system is analyzed to gather its functionalities use cases are prepared and actors are identified. 

 
So in brief, the purposes of use case diagrams can be as follows:  

   Used to gather requirements of a system.  
   Used to get an outside view of a system.  


  Identify external and internal factors influencing the system.   Show the 
interacting among the requirements are actors  

 
Withdrawal Use Case: 

 
A withdrawal transaction asks the customer to choose a type of account to withdraw from (e.g. checking) 

from a menu of possible accounts, and to choose a dollar amount from a menu of possible amounts. The 

system verifies that it has sufficient money on hand to satisfy the request before sending the transaction 

to the bank. (If not, the customer is informed and asked to enter a different amount.) If the transaction is 

approved by the bank, the appropriate amount of cash is dispensed by the machine before it issues a 

receipt. A withdrawal transaction can be can-celled by the customer pressing the Cancel key any time 

prior to choosing the dollar amount. 

 
Deposit Use Case: 

 
A deposit transaction asks the customer to choose a type of account to deposit to (e.g. checking) from a 

menu of possible accounts, and to type in a dollar amount on the keyboard. The transaction is initially 

sent to the bank to verify that the ATM can accept a deposit from this customer to this account. If the 

transaction is approved, the machine accepts an envelope from the customer containing cash and/or 

checks before it issues a receipt. Once the envelope has been received, a second message is sent to the 

bank, to confirm that the bank can credit the customer‗s account – contingent on manual verification of 

the deposit envelope contents by an operator later. 

 
A deposit transaction can be cancelled by the customer pressing the Cancel key any time prior to 
inserting the envelope containing the deposit. The transaction is automatically cancelled if the customer 
fails to insert the envelope containing the deposit within a reasonable period of time after being asked to 
do so. 

 
Transfer Use Case: 

 
A transfer transaction asks the customer to choose a type of account to transfer from (e.g. checking) from 
a menu of possible accounts, to choose a different account to transfer to, and to type in a dollar amount 
on the keyboard. No further action is required once the transaction is approved by the bank before 

printing the receipt. A transfer transaction can be cancelled by the customer pressing the Cancel key any 
time prior to entering a dollar amount. 



Inquiry Use Case: 
 

An inquiry transaction asks the customer to choose a type of account to inquire about from a menu of 
possible accounts. No further action is required once the transaction is approved by the bank before 
printing the receipt. An inquiry transaction can be cancelled by the customer pressing the Cancel key any 
time prior to choosing the account to inquire about. 

 
Validate User use case: 

 
This use case is for validate the user i.e. check the pin number, when the bank reports that the customer‗s 

transaction is disapproved due to an invalid PIN. The customer is required to re-enter the PIN and the 

original request is sent to the bank again. If the bank now approves the transaction, or disapproves it for 
some other reason, the original use case is continued; otherwise the process of re-entering the PIN is 

repeated. Once the PIN is successfully re-entered. 

 
If the customer fails three times to enter the correct PIN, the card is permanently retained, a screen is 
displayed informing the customer of this and suggesting he/she contact the bank, and the entire customer 
session is aborted. 

 
Print Bill use case:  
This use case is for printing corresponding bill after transactions (withdraw or deposit ,or balance 
enquiry, transfer) are completed. 

 
Update Account:  
This use case is for updating corresponding user accounts after transactions (withdraw or deposit or 
transfer) are completed. 

 
 
1.4 PROCEDURE:  
 

1. Open folder Use Case View. Name your use case diagram.   
2. Double click on the Use Case View icon or right click on Use Case View and select Open.  

 
3. Now click on the icon for actor and draw an actor on use case view diagram. Actor will 

represent your user or the client, which will interact with your system.  
4. Now click on the icon for use case and draw use cases for the system.  
5. Now click on the appropriate arrow for the relation between actor and use case.   
6. Click on the package and show appropriate relation among these three entities.  

 

1.5 A. USE CASE DIAGRAM FOR ATM  



B. USECASE DIAGRAM FOR ATM TRANSACTION  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
1.6 PRE LAB VIVA QUESTIONS:  
 

1. What are the nine types of UML Diagrams?  
 

2. What is Use case Diagram?  
 

3. What is the role of an Actor in Use case Diagram?  
 

4. Which are the common modeling techniques for a Use case Diagram?  
 

5. What are the different relationships used in Use case Diagram?  
 
 

1.7 LAB ASSIGNMENT:  
 

1. Identify actors in Airport check-in and security screening business model?  
 

2. Design a Use case diagram for restaurant?  
 

3. Show that ticket vending machine allows from commuters to buy tickets using Use case Diagram?  
 

4. Design Use case Diagram for e-library online public access catalog?  
 

5. Define major Use cases for a credit card processing system?  

 

1.8 POST LAB VIVA QUESTIONS:  

 

1. What are main flow of events and exception flow of events in use cases ?  
 

2. How Use cases realize collaborations?  
 

3. What are extend and include stereotypes?  
 

4. Can we organize use cases into packages?  
 

5. How to forward engineering and reverse engineering in Use case Diagram?  



WEEK – 1 (B) 
 
1.1 OBJECTIVE:  
 

Generate a Class Diagram for ATM System.  

 

1.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  
 

 

1.3 DESCRIPTION:  

 

The purpose of the class diagram is to model the static view of an application. The class diagrams are 

the only diagrams which can be directly mapped with object oriented languages and thus widely used 

at the time of construction. The UML diagrams like activity diagram, sequence diagram can only give 

the sequence flow of the application but class diagram is a bit different. So it is the most popular UML 

diagram in the coder community. So the purpose of the class diagram can be summarized as:  

 

 Analysis and design of the static view of an application  

 Describe responsibilities of a system.  
 

 Base for component and deployment 
diagrams.  Forward and reverse engineering.  

 

Contents:  
Class diagrams commonly contain the following things  

 

   Classes  
   Interfaces  


   Collaborations  


  Dependency, generalization and association relationships  
 
 
1.4 PROCEDURE:  
 

1. The Logical View Class Diagram window may already be open. If so, skip to step 3.  
 

2. Open the Logical View Folder. Double click on the icon next to Main. (Alternately, right click 
on Main and select Open).  

 
3. To draw a class, click on the class icon on the toolbar. Move the cross bar to the class 

diagram window and click.  
 

4. Name the class. Note that you do not want to use the same name as an Actor in your Use Case 
diagram. For example, if you have a Student actor, the class should be named Student Proxy.  

5. Now right click on the class to add attributes and methods to your class.  
 

6. Create all the classes you require for your class model. Using the connection symbols from the 
toolbar, connect the classes to show the relationship between those two classes (association, 
generalization/specialization or aggregation). Do the same for all the classes.  

7. You can name associations using text box in the tool bar.   
8. To add multiplicity information, right click on the association line and select the desired value.  



1.5 CLASS DIAGRAM FOR ATM  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
1.6 PRE LAB VIVA QUESTIONS:  
 

1. Define class and object?   
2. Explain about contents of Class Diagram?   
3. Compare aggregation and composition in Class Diagram?   
4. Which are the common modeling techniques for a Class Diagram?   
5. What are the different relationships used in Class Diagram?  

 

1.7 LAB ASSIGNMENT:  
 

1. Draw a Class Diagram for Railway reservation System?   
2. Design a Class Diagram for restaurant?   
3. Design Class Diagram for Library Management System?   
4. Draw a Class Diagram for managing school information?   
5. Model a Class Diagram for online shopping?  

 

1.8 POST LAB VIVA QUESTIONS:  

 

1. How Interfaces are implemented by classes?   
2. Explain about structural diagrams?   
3. How to model logical database schema?   
4. Explain modeling of a distributed system using class and collaboration?  

5. What is meant by responsibilities?  



WEEK – 2(A) 
 
2.1 OBJECTIVE:  
 

Generate a Sequence Diagram for ATM System.  

 

2.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  

 

2.3 DESCRIPTION:  

 

We have two types of interaction diagrams in UML. One is sequence diagram and the other is a 
collaboration diagram. The sequence diagram captures the time sequence of message flow from one 
object to another and the collaboration diagram describes the organization of objects in a system taking 
part in the message flow.  

 

So the following things are to identified clearly before drawing the interaction diagram:  

 
1. Objects taking part in the interaction.  

 
2. Message flows among the objects.   
3. The sequence in which the messages are flowing.   
4. Object organization.  

 
Purpose: 

 
1. To capture dynamic behavior of a system.   
2. To describe the message flow in the system.   
3. To describe structural organization of the objects.   
4. To describe interaction among objects.  

 
Contents of a Sequence Diagram 

 
a. Objects   
b. Focus of control   
c. Messages   
d. Life line  
e. Contents  

 

 

2.4 PROCEDURE:  
 

1. From Use Case View, Click to highlight the Use Case name.   
2. Right click and select New.   
3. Select Sequence Diagram and type a name for the diagram in the browser.   
4. You can now double click the icon next the name to open the sequence diagram window.  

 
5. To put actors on the sequence diagram, in the browser, under Use Case View, click on the desired 

actor and drag it onto the sequence diagram window.  
 

6. To put objects on the sequence diagram, in the browser, under Logical View, click on the desired 
class and drag it onto the sequence diagram window.   

7. Note that if you use the toolbar to put an object on the sequence diagram, the tool will ask you 
for its class. If the class doesn‘t exist in your Logical View, you will have to create it.  

 
8. The tool will place your actors and objects from left to right in the order you select them. Once 

they are in the window, you can rearrange in the usual manner.  
 

9. To add a message in the toolbar, select the message arrow, Click on the lifeline of the source of 
the message and drag to the lifeline of the destination of the message.  

 
10. To add a message name, Right click on the message arrow. You can either select one of the 

existing messages, or select <new operation> to add a new message.  



2.5 A. SEQUENCE DIAGRAM FOR ATM 



B. SEQUENCE DIAGRAM FOR INVALID PIN ATM  



C. SEQUENCE DIAGRAM FOR ATM WITHDRAWAL  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
2.6 PRE LAB VIVA QUESTIONS:  
 

1. What is meant by link?   
2. Explain about flat sequence?   
3. What are the steps to model flow of control?   
4. Define sequence diagram?   
5. What is focus of control?  

 

2.7 LAB ASSIGNMENT:  
 

1. Identify objects in online shopping?   
2. Design a sequence diagram for online banking?   
3. Design sequence for hospital management system?   
4. Design sequence Diagram for e-library online public access catalog?   
5. Define major sequence for a credit card processing system?  

 

 

2.8 POST LAB VIVA QUESTIONS:  

 
1. Explain about object line in sequence diagram?   
2. What are the steps to forward engineer a sequence diagram?  
3. What are the steps to reverse engineer a sequence diagram?  

4. What are time and space constraints?   
5. What are the uses of sequence diagram?  



WEEK – 2 (B) 
 
2.1 OBJECTIVE:  
 

Generate a Collaboration Diagram for ATM System.  

 

2.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  
 

 

2.3 DESCRIPTION:  
 

A collaboration diagram emphasizes the organization of the objects that participate in an interaction. 
Collaboration diagrams have two features that distinguish them from sequence diagrams.  

 
1. Path  
2. The Sequence number.  

 
Contents of a Collaboration Diagram 

 
1. Objects   
2. Links   
3. Messages  

 
2.4 PROCEDURE:  

 
1. If you have not yet drawn a sequence diagram, follow steps 1-3 in ―Drawing a Sequence 

Diagram‖, except select Collaboration Diagram in step 3. The steps to put actors and objects on the 
diagram are similar.  

 
2. If you have an existing sequence diagram, you can have the tool generate a collaboration diagram 

for you:  
i. In the browser click on the name of the sequence diagram to highlight it  

ii. Pull down the Browse menu from the menu bar at the top   
iii. Select Create Collaboration Diagram  

 
3. The Collaboration Diagram window will appear with all the objects, actors and messages from the 

sequence diagram. You may have to rearrange the symbols on the diagram to increase readability. But 
if your sequence diagram is correct, you will not have to add any new information to the diagram.  

 

 

2.5 A.  COLLABORATIONDIAGRAM FOR ATM  



B. COLLABORATION DIAGRAM FOR INVALID PIN ATM  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
C. COLLABORATION DIAGRAM FOR ATM WITHDRAWAL  



2.6 PRE LAB VIVA QUESTIONS:  
 

1. Define interaction diagram?   
2. Explain collaboration diagram?.   
3. What are the uses of interaction diagram?  
4. Explain modeling flow of organization?   
5. What are the uses of collaboration diagram?  

 
2.7 LAB ASSIGNMENT:  

 
1. Draw a collaboration diagram for library management system?   
2. Design objects in collaboration diagrams?   
3. Design a collaboration diagram for hospital management system?   
4. Draw a collaboration diagram for website administration system?   
5. Draw a collaboration diagram for digital image communication?  

 
2.8 POST LAB VIVA QUESTIONS:  
 

1. How to model forward engineer a collaboration diagram?  
2. What are the steps to reverse engineer a collaboration diagram?   
3. Difference between sequence diagram and collaboration diagram ?  

4. Compare become and copy stereotypes?  
5. What are time and space constraints?  



WEEK – 3 (A) 
 
3.1 OBJECTIVE:  
 

Generate a State Diagram for ATM System.  

 

3.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  

 

3.3 DESCRIPTIONS:  

 

State chart diagram is used to model dynamic nature of a system. They define different states of an 
object during its lifetime. And these states are changed by events. So State chart diagrams are useful 
to model reactive systems. Reactive systems can be defined as a system that responds to external or 
internal events.  

 
State chart diagram describes the flow of control from one state to another state. States are defined as a 
condition in which an object exists and it changes when some event is triggered. So the most important 
purpose of State chart diagram is to model life time of an object from creation to termination.  

 
State chart diagrams are also used for forward and reverse engineering of a system. But the main 
purpose is to model reactive system.  

 
Following are the main purposes of using State chart diagrams:  

 

1. To model dynamic aspect of a system.   
2. To model life time of a reactive system.   
3. To describe different states of an object during its life time.   
4. Define a state machine to model states of an object.  

 
Contents 

 
Simply state and composite states Transitions, including events and actions 

 
Common use 

 
They are used to model the dynamic aspects of a system. Event ordered behavior of any kind of 
objects, to model reactive objects. 

 
 
3.4 PROCEDURE:  

 
1. Create a state machine when behavior differs based on state. a seminar object is fairly complex, 

reacting to events such a enrolling a student differently depending on its current state.  

2. Place the initial state in the top-left corner.  
3. Place the final state in the bottom-right corner.   
4. Model sub states for targeted complexity.  



3.5 A. STATE DIAGRAM FOR ATM  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
B. STATECHART DIAGRAM FOR VALIDATION  



3.6 PRE LAB VIVA QUESTIONS:  
 

1. Compare activity and action states?   
2. Define action states?   
3. What are transitions?  
4. What are branches?   
5. Compare fork and join?  

 
3.7 LAB ASSIGNMENT:  

 
1. Design water phase diagram using state chart diagram?   
2. Draw state chart diagram for ATM state machine?  
3. Design online shopping user account machine?   
4. Draw state machine for ticket vending?   
5. Design state machine for real estate business problem?  

 
3.8 POST LAB VIVA QUESTIONS:  
 

1. What are swim lanes?  
2. How to model workflow in activity diagram?  
3. How to model operations?  
4. How to forward and reverse engineer an activity diagram?  
5. What are the uses of an activity diagram?  



WEEK – 3 (B) 
 
3.1 OBJECTIVE:  
 

Generate an Activity Diagram for ATM System.  

 

3.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  
 
3.3 DESCRIPTION:  

 

Activity diagram is basically a flow chart to represent the flow form one activity to another. The activity 
can be described as an operation of the system. So the control flow is drawn from one operation to 
another. This flow can be sequential, branched or concurrent. Activity diagrams deals with all type of 
flow by using elements like fork join etc.  

 

Contents  
 

Initial/Final State, Activity , Fork & Join, Branch, Swim lanes.  
 

Fork  
 

A fork represents the splitting of a single flow of control into two or more concurrent flow of control. A 
fork may have one incoming transition and two or more outgoing transitions, each of which represents an 
independent flow of control. Below fork the activities associated with each of these path continues in 
parallel.  

 

Join  
 

A join represents the synchronization of two or more concurrent flows of control. A join may have two or 
more incoming transition and one outgoing transition. Above the join the activities associated with each 
of these paths continues in parallel.  

 

Branching  
 

A branch specifies alternate paths takes based on some Boolean expression Branch is represented by 
diamond Branch may have one incoming transition and two or more outgoing one on each outgoing 
transition, you place a Boolean expression shouldn‗t overlap but they should cover all possibilities.  

 

Swim lane:  
 

Swim lanes are useful when we model workflows of business processes to partition the activity states on 
an activity diagram into groups. Each group representing the business organization responsible for those 
activities, these groups are called Swim lanes.  

 
 

3.4 PROCEDURE:  
 

1. Identify the scope of the activity diagram.   
2. Add start and end points.  
3. Add activities.   
4. Add transitions from the activities.   
5. Add decision points.   
6. Identify opportunities for parallel activities.  



3.5 ACTIVITY DIAGRAM FOR ATM  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
3.6 PRE LAB VIVA QUESTIONS:  
 

1. Define state?   
2. What are events?   
3. What are the different state parts?  
4. What are different transition parts?  

5. Explain guard condition?  

 

3.7 LAB ASSIGNMENT:  

 
1. Draw an activity diagram for process purchase order?   
2. Design an activity diagram for Electronic medical prescription service?  

3. Draw an activity diagram for online shopping?  
4. Design an activity diagram for ticket vending?  
5. Draw an activity diagram for single sign for Google security?  

 

3.8 POST LAB VIVA QUESTIONS:  
 

1. Explain deferred events?  
2. Explain about sequential sub states?  
3. What are history states?  
4. Explain about concurrent sub states?  
5. What are the steps for modeling lifetime of an object?  



WEEK – 4 (A) 
 
4.1 OBJECTIVE:  
 

Generate a Component Diagram for ATM System.  

 

4.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  
 

 

4.3 DESCRIPTION:  
 

Component diagrams can be described as a static implementation view of a system. Static 
implementation represents the organization of the components at a particular moment. A single 
component diagram cannot represent the entire system but a collection of diagrams are used to represent 
the whole.   
Before drawing a component diagram the following artifacts are to be identified clearly:  

 

  Files used in the system.  
 

  
 

  Libraries and other artifacts relevant to the application.  
 

  
 

  Relationships among the artifacts.  
 

 
 

Now after identifying the artifacts the following points needs to be followed: 
 

  Use a meaningful name to identify the component for which the diagram is to be drawn.  
 

  
 

  Prepare a mental layout before producing using tools.  
 

  
 

  Use notes for clarifying important points.  
 

 
Now the usage of component diagrams can be described as: 

  Model the components of a system.  
  Model database schema.  


  Model executable of an application.  


 Model system‗s source code.  
 

Contents 
 

Components, Interfaces, Relationships. 
 
4.4 PROCEDURE:  

 
1. First component are created.   
2. Packages are created.  
3. Draw component s in the packages.  

4. Draw the relationship between various components.  



4.5 COMPONENT DIAGRAM FOR ATM  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
4.6 PRE LAB VIVA QUESTIONS:  

 
1. Define components?   
2. How components and classes are related?  
3. Compare components and interfaces?  

4. What are the steps for modeling executable and libraries?   
5. What are different modeling techniques?  

 
4.7 LAB ASSIGNMENT:  

 
1. Draw a component diagram for retail website?  
2. Design a component diagram for online banking?  

3. What are the main components in sentinel website?   
4. Draw components in web application?   
5. Design a component diagram for online shopping?.  

 

4.8 POST LAB VIVA QUESTIONS:  
 

1. What are the steps for modeling source code?  
2. What are different relationships used in components?  
3. How to model physical databases in component diagram?  
4. How components are rendered in UML?  
5. What are the uses of component diagram?  



WEEK – 4 (B) 
 
4.1 OBJECTIVE:  
 

Generate a Deployment  Diagram for ATM System.  

 

4.2 RESOURCES:  
 

1. A working computer system with either Windows or Linux.  
 

2. Rational Rose Software or Visual Paradigm Software.  
 

 

4.3 DESCRIPTION:  

 
Deployment diagram depicts a static view of the run-time configuration of processing nodes and the 
components that run on those nodes. In other words, deployment diagrams show the hardware for your 
system, the software that is installed on that hardware, and the middleware used to connect the disparate 
machines to one another.  

 
You want to create a deployment diagram for applications that are deployed to several machines, for 
example a point-of-sales application running on a thin-client network computer which interacts with 
several internal servers behind your corporate firewall or a customer service system deployed using a web 
services architecture such as Microsoft's .NET. Deployment diagrams can also be created to explore the 
architecture of embedded systems, showing how the hardware and software components work together. In 
short, you may want to consider creating a deployment diagram for all but the most trivial of systems.  

 

4.4 PROCEDURE:  

 
1. Identify the scope of the model.   
2. Consider fundamental technical issues.  
3. Identify the distribution architecture.  

4. Identify the nodes and their connections.   
5. Distribute software to nodes.  

 

 

4.5 DEPLOYMENT DIAGRAM FOR ATM  



4.6 PRE LAB VIVA QUESTIONS:  
 

1. Define node?   
2. Compare node and components?   
3. What are the contents of deployment diagrams?  
4. How a node is rendered in UML?   
5. How to model a fully distributed model?  

 
4.7 LAB ASSIGNMENT:  

 
1. Draw a deployment diagram for website application?   
2. Design a deployment diagram for online banking?  
3. What are the main nodes in clustered deployment J2ee website?   
4. Draw deployment diagram in multi layered web balancing?   
5. Design a deployment diagram for apple iTunes?  

 
4.8 POST LAB VIVA QUESTIONS: 

 
1. What are the steps to model embedded cod e?  
2. What are the steps to model client server system?  
3. Explain the uses of deployment diagram?  
4. What are the different relationships used in deployment diagram?  
5. What are modeling techniques of deployment diagrams?  



 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

SOFTWARE TESTING 
 

LAB 



WEEK – 5  
5.1  OBJECTIVE: 
 

Write a ‗C‘ program to demonstrate the working of the following constructs: 
i. do…while  

ii. while…do  
iii. if …else  
iv. switch  
v. for Loops in C language.  

 
5.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  

 

5.3 PROGRAM LOGIC:  
 

i) do …while  

 
declare i, intialize n to 5 and j to 0. 
read i value .  
loop : if i%2== 0 print i as even number. 

and increment i and j value.  
otherwise print i as odd number . 

and increment i and j value . 
if i>0 and j<n go to loop . 

 
ii) while…do 

 
declare i, intialize n to 5 and j to 0. 
read i value . 
loop :  if i>0 and j<n. 

 
if i%2 == 0 print i as even number . 

and increment i and j value.  
otherwise print i as odd number . 

and increment i and j value . 
go to loop 

 
iii) if….else 

 
declare i value. 
read i value .  
if i%2== 0 print i as even number. 
otherwise odd number. 

 
iv) switch 

 
declare a,b,c. 
read i value.  
print enter a,b values . 
read a,b values . 
switch ( case value = i) 

if case value = 1 
 

c is sum of a and b 
. if case value =2  
c is difference of a and b 
. if case value = 3  
c is multiplication of a 
and b. if case value = 4 
c is division of a and b . 

 

 
v) for loop declare  

i value.  



read i value . 
 

loop initialize i to 
1 if i<=5 
print i as even number.  

else 
 

print i as odd number. 
increment i value . 

 
 
5.4 PROCEDURE:  
 

1. Create : Open editor vi  x.c write a program after that press ESC and: wq for save and Quit.  
 

2. Compile: gcc x.c.  
 

3. Execute: . / a.out.  

 

5.5 SOURCE CODE: 

i) do…while  

 
#include <stdio.h> 
void main () 
{ 

 
int i, n=5,j=0; 

printf(―enter a no‖); 
scanf(―%d‖,&i); 
do  
{  

if(i%2==0)  
{ 

 
printf("%d", i); 
printf("is a even no."); 
i++; 
j++;  

}  
else  

{  
printf("%d", i);  
printf("is a odd no.\n"); 
i++; j++;  

}  
}while(i>0&&j<n); 
getch();  

} 
 

ii) while…do 

 
#include<stdio.h> 
#include <conio.h> 
void main () 
{ 

 
int i,n=5,j=1; 
printf(―enter a no‖); 
scanf(―%d‖,&i); 

while (i>0 && j<n)  
{  

if(i%2==0)  
{ 
printf(―%d‖,i); 

 
printf(―is a even number‖); 

i++; 
j++; 

}  
else  
{ 



printf(―%d‖,i); 
 

printf(―its a odd number‖); 
i++; 
j++;  

} 
 

}  
getch();  

} 
 
iii) if….else 
 
void main ()  
{ 
int I,c; 
 
printf(―enter a number ―); 
scanf(―%d‖,&i); if(i%2==0) 
 
{  

printf(―%d‖,i);  
printf(―s a even number‖);  

}  
else  
{  

printf(―%d‖,i);  
printf(―is a odd number‖);  

} 
 
} 
 
iv) switch 
 
void main() 
{  
int 
a,b,c; 
 
printf(―1.add/n 2.sub /n 3.mul /n 4.div /n enter your 
choice‖); scanf(―%d‖ , &i); 

 
printf(―enter a,b values‖); 

scanf(―%d%d‖,&a,&b); 
switch(i) 

{  
case 1: c=a+b; 

 
printf(―the sum of a & b is: %d‖,c); break; 
case 2: c=a-b; 

 
printf(― the diff of a & b is: %d‖ ,c); 
break; case 3: c=a*b; 

 
printf(―the mul of a & b is: %d‖,c); 
break; case 4: c=a/b; 

 
printf(― the div of a & b is: %d‖ ,c); break; 
default:  
printf(―enter your choice‖); break;  

} 
getch();  
} 
 
v) for 
 
main() 
{ 
 
int i; 
 
printf(―enter a no‖); 
scanf(―%d‖,&i); 

for(i=1;i<=5;i++) 



{  
if(i%2==0) 
{ 

printf(―%d‖, i); 
 

printf(―is a even 
no‖); i++; 

} 
else  
{ 

 
printf(―%d‖, i); 
printf(―is a odd 
no‖); i++; 

}  
}  

getch();  
} 

 
5.6 INPUT AND OUTPUT:  
 

i. do…while  

 
Input Actual output 

 
2 2 is even number  

3 is odd number   
4 is even number  
5 is odd number 
6 is even number 

 
 

Test cases:   

Test case no: 1   
Test case name: Positive values within range  

    

Input Expected output Actual output Remarks 
2 2 is even number 2 is even number  

 3 is odd number 3 is odd number  

 4 is even number 4 is even number Success 
 5 is odd number 5 is odd number  

 6 is even number 6 is even number  

Test case no: 2   
Test case name: Negative values within a range  

 

 Input Expected output Actual output  Remarks   
 2 -2 is even number -2 is an even number   fail   

  -3 is odd number       

  -4 is even number       
  -5 is odd number       

  -6 is even number       
          

Test case no: 3       
Test case name: Out of range values testing     

        

  Input  Expected output  Actual output Remarks 
       

 1234567891222222222222  123456789122222222213  234567891222222215 fail 



ii. while…do  
 

Input Actual output 
  

2 2 is even number 
 3 is odd number 
 4 is even number 
 5 is odd number 
 6 is even number 
  

 
Test cases:  
Test case no: 1 
Test case name: Positive values within range 

 
 Input Expected output  Actual output Remarks    
 2  2 is even number  2 is even number  success    

   3 is odd number  3 is odd number        

   4 is even number  4 is even number        

   5 is odd number  5 is odd number        

   6 is even number  6 is even number        
             

 Test case no:2          
 Test case name: Negative values within a range        

            

 Input  Expected output  Actual output   Remarks   

 -2  -2 is even number  -2 is an even  number  fail   

   -3 is odd number          

   -4 is even number          

   -5 is odd number          

   -6 is even number          

 Test case no: 3          
 Test case name: Out of range values testing        

           

   Input  Expected output    Actual output Remarks 
      

 1234567891222222222222  123456789122222222213 234567891222222215 fail 

 
iii. if …else  

 
Input Actual output 

  

2 2 is even number 
 3 is odd number 
 4 is even number 
 5 is odd number 
 6 is even number 
  

 
Test cases:  
Test case no: 1 
Test case name: Positive values within range 

 

Input Expected output Actual output Remarks 
    

2 2 is even number 2 is even number success 
 3 is odd number 3 is odd number  

 4 is even number 4 is even number  

 5 is odd number 5 is odd number  

 6 is even number 6 is even number  

 
 

Test case no:2 
Test case name: Negative values within a range. 



 Input Expected output  Actual output Remarks   
         

 -2 -2 is even number -2 is an even number fail   

  -3 is odd number       

  -4 is even number       

  -5 is odd number       

  -6 is even number       

Test case no: 3       
Test case name: Out of range values testing     

        

  Input  Expected output  Actual output Remarks 
      

1234567891222222222222  123456789122222222213  234567891222222215 fail 
         

 
iv. switch  
 

 Input    Actual output        
 

               

 Enter Ur choice: 1             
 

 Enter a, b Values: 3, 2   The sum of a & b is:5        
 

 Enter Ur choice: 2   The diff of a & b is: 1        
 

 Enter a, b Values: 3, 2             
 

 Enter Ur choice: 3   The Mul of a & b is: 6       
 

 Enter a, b Values: 3, 2             
 

 Enter Ur choice: 4   The Div of a & b is: 1        
 

 Enter a, b Values: 3, 2             
 

               
 

Test cases:              
 

Test case no: 1              
 

Test case name: Positive values within range        
 

             
 

 Input    Expected output   Actual output Remarks 
 

               

 Enter Ur choice: 1             
 

 Enter a, b Values: 3, 2   The sum of a & b is:5  5    
 

 Enter Ur choice: 2             
 

 Enter a, b Values: 3, 2   The diff of a & b is: 1  1  
Success 

 

 
Enter Ur choice: 3           

 

             
 

 Enter a, b Values: 3, 2   The Mul of a & b is: 6  6    
 

 Enter Ur choice: 4             
 

 Enter a, b Values: 3, 2   The Div of a & b is: 1  1    
 

Test case no:2              
 

Test case name: Out of range values testing        
 

           
 

 Input    Expected output  Actual output Remarks  
 

 Option: 1  44444444444444   -2  fail  
 

 a= 22222222222222             
 

 b=22222222222222             
 

                
 

Test case no: 3              
 

Test case name: Divide by zero          
 

               
 

 Input  Expected output Actual output Remarks   
 

 Option: 4   error      fail    
 

 a= 10 & b=0               
 

                 



v. for loop  

 
Test case no: 1 
Test case name: Positive values within range 

 
 Input Expected output   Actual output  Remarks     
             

 2 0 is even number  0 is even number  success     

  1 is odd number  1 is odd number        

  2 is even number  2 is even number        
             

Test case no: 2           
Test case name: Negative values within a range       

           

 Input Expected output   Actual output  Remarks   
           

 -2 0 is even number   0 is an even number  fail   

  -1 is odd number   -1 is even number       

  -2 is even number   -2 is odd number       
             

Test case no: 3           
Test case name: Out of range values testing       

         

  Input   Expected output  Actual output Remarks 
        

 1234567891222222222222   123456789122222222213   234567891222222215 fail 
             

 
 
 
5.7 PRE LAB VIVA QUESTIONS:  

 
1  What are different loop statements in C?  
2  Compare entry controlled and exit controlled loops?  

3  What is the use of break statement?   
4  Compare different if statements in C?   
5  State different data types and ranges in C?  

 

5.8 LAB ASSIGNMENT:  

 
1 Demonstrate the working of nested if in C language? 2 
Demonstrate the working of simple if in C language?  

 
3 Design test cases for preprocessor commands in C language? 
4 Demonstrate the working of go to statement in C language? 5 
Design test cases for structures in C language?  

 

5.9 POST LAB VIVA QUESTIONS:  
 

1  Define model for testing?  

2  How to design test cases?   
3  Give syntax for if …else statement?  

 
4 Give the syntax for nested if in C statement? 5 
Compare different testing techniques?  



WEEK – 6  
6.1 OBJECTIVE:  

 
A program written in c language for matrix multiplication fails ―Introspect the causes for its failure 
and write down the possible reasons for its failure‖. 

 
6.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  
 

6.3 PROGRAM LOGIC :  
 

1. Read the no. of rows (r1) and cols (c1) of a matrix a[3][3].  
 

2. Read the no. of rows (r2) and cols. (c2) of matrix b[3][3].  
 

3. If c1=r2 then display matrix multiplication is possible otherwise display impossible  
 

4. If c1=r2 then read the elements into both the matrices a and b.  
 

5. Initialize a resultant matrix c[3][3] with 0.  
 

6. Calculate c[i][j] = c[i][j] + a[i][k] * b[k][j].  
 

7. Display the resultant matrix.  

 

6.4 PROCEDURE:  
 

a. Create : Open editor vi  x.c write a program after that press ESC and: wq for save and Quit.   
b. Compile: gcc x.c.   
c. Execute: . / a.out.  

 

 

6.5 SOURCE CODE :  

#include<stdio.h> 
 

#include<conio.h> 
void main()  
{ 

 
int a[3][3],b[3][3],c[3][3],i,j,k,m,n,p,q; 
clrscr();  
printf(―Enter 1

st
 matrix no.of rows 

& cols); scanf(―%d%d‖,&m,&n);  
printf(― Enter 2

nd
 matrix no.of rows & 

cols‖) ; scanf(―%d%d‖,&p,&q);  
printf("\n enter the matrix 
elements"); for(i=0;i<m;i++) 

{  
for(j=0;j<n;j++)  
{  

scanf("%d",&a[i][j]);  
}  

} 
 

printf("\n a matrix 
is\n"); for(i=0;i<m;i++)  

{ 
for(j=0;j<n;j++)  
{  

printf("%d\t",a[i][j]);  
} 
printf("\n");  

}  
for(i=0;i<p;i++)  

{  
for(j=0;j<q;j++)  
{ 



scanf("%d\t",&b[i][j]);  
}  

} 
 

printf("\n b matrix is\n"); 
 

for(i=0;i<p;i++)  
{  

for(j=0;j<q;j++) 
{  

printf("%d\t",b[i][j]);  
}  

printf("\n");  
} 

 
for(i=0;i<m;i++)  

{  
for(j=0;j<q;j++)  
{  

c[i][j]=0;  
for(k=0;k<n;k++)  
{  

c[i][j]=c[i][j]+a[i][k]*b[k][j];  
}  

} 
} 

 
for(i=0;i<m;i++)  

{  
for(j=0;j<q;j++)  
{  

printf("%d\t",c[i][j]);  
}  

printf("\n"); 
}  
getch();  

} 
 
 

 
6.6 INPUT AND OUTPUT:  
 

Input Actual Output 
Matrix1:   

1 1 1   

1 1 1   

1 1 1 3 3 3 
Matrix2: 3 3 3 

1 1 1 3 3 3 
1 1 1   

1 1 1   

   



Test cases:  
Test case no: 1 
Test case name: Equal no. of rows & cols 

 

Input Expected output Actual output Remarks 
 

Matrix1 rows & cols= 3 3        
 

Matrix2 rows & cols= 3 3        
 

Matrix1:        
 

1 1 1  
3 3 3 

 
3 3 3 

 
 

1 1 1    
 

3 3 3 3 3 3 Success  

1 1 1  

 
3 3 3  

3 3 3  
 

Matrix2:    
 

       
 

1 1 1        
 

1 1 1        
 

1 1 1        
 

Test case no: 2        
 

Test case name: Cols of 1
st

matrix not equal to rows of 2
nd

matrix  
 

 

Input Expected output Actual output Remarks 
Matrix1 rows & cols= 2 2 Operation can‘t be performed    fail 
Matrix2 rows & cols= 3 2       

       

Test case no: 3       
Test case name: Out of range values testing     

      
Input Expected output Actual output Remarks   

Matrix1 rows & cols= 2 2    fail   

Matrix2 rows & cols= 2 2       

1234567891 2222222222       
2234567891 2222222221       

234567891 22222221533       
213242424 56456475457       

 

 
6.7 PRE LAB VIVA QUESTIONS:  

 
1. What is an array?   
2. State 2-dimensional and multi-dimensional array syntax?  
3. Difference between array and structure?  

4. What is a structure and specify its syntax?   
5. Write syntax for multidimensional arrays?  

 

6.8 LAB ASSIGNMENT:  
 

1. Write a C Program to print addition of 3-dimensional matrices?   
2. Write a C Program to print student details using structures?  
3. Write a C Program to print employee details using pointer to structures?  

4. Write a C Program to print student details using pointers?   
5. Write a C Program to show the working of double pointers?  

 
6.9 POST LAB VIVA QUESTIONS:  

 
1. Define pointer. Give its syntax?  

2. What is double pointer?   
3. Difference between structure and arrays?   
4. What is pointer to structure?   
5. What are multidimensional arrays?  



WEEK – 7 (A)  
7.1 OBJECTIVE:  
 

Take any system (e.g. ATM system) and study its system specifications and report the various bugs.  

 

7.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  
 

7.3 BUGS IN ATM SYSTEM:  
 

1. Machine is accepting ATM card.   
2. Machine is rejecting expired card.  
3. Successful entry of PIN number.  

4. Unsuccessful operation due to enter wrong PIN number 3 times.   
5. Successful selection of language.   
6. Successful selection of account type.   
7. Unsuccessful operation due to invalid account type.   
8. Successful selection of amount to be withdrawn.   
9. Successful withdrawal.   
10. Expected message due to amount is greater than day limit.  
11. Unsuccessful withdraw operation due to lack of money in ATM.  

12. Expected message due to amount to withdraw is greater than possible balance.  
13. Unsuccessful withdraw operation due to click cancel after insert card.  

 

7.4 PRE LAB VIVA QUESTIONS:  

 
1. What are design specifications?   
2. What are different types of bugs?  

3 .Compare functional and structural testing? 

. 4 .Explain dichotomies of testing? 5 
.What are consequences of bugs? 

 
7.5 LAB ASSIGNMENT:  

 
1 What can be bugs for online library?  
2 Write down the bugs for hospital management system?  

3 What can system specifications for online banking?   
4 What can system specifications for online shopping?   
5 What can system specifications for hotel management system?  

 
7.6 POST LAB VIVA QUESTIONS:  

 
1 What are test design bugs?  

2 Explain about nightmare list?  
3 What are levels of testing?  

4 Compare small versus large programming?   
5 Define pesticide paradox?  



WEEK – 7 (B)  
7.1 OBJECTIVE:  
 

Write the test cases for any known application (e.g. Banking application) 
 
 
7.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 2K 

server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win  

95/98/NT/2K/XP, IE 5. 
 
7.3 TEST CASES FOR BANKING APPLICATION:  

 

1. Checking mandatory input parameters.   
2. Checking optional input parameters.   
3. Check whether able to create account entity.  

 
4. Check whether you are able to deposit an amount in the newly created account (and thus 

updating the balance).   
5. Check whether you are able to withdraw an amount in the newly created account (after deposit) 

(and thus updating the balance).   
6. Check whether company name and its pan number and other details are provided in case of 

salary account.   
7. Check whether primary account number is provided in case of secondary account.  
8. Check whether company details are provided in cases of company's current account.  
9. Check whether proofs for joint account are provided in case of joint account.  

 
10. Check whether you are able deposit an account in the name of either of the person in a 

joint account.  
 

11. Check whether you are able withdraws an account in the name of either of the person in a joint 
account.  

12. Check whether you are able to maintain zero balance in salary account.  
 

13. Check whether you are not able to maintain zero balance (or mini balance) in non-salary 
account.  

 
7.4 PRE LAB VIVA QUESTIONS:  
 

1. What is flow graph testing?   
2. Difference between flow graph and control graph?   
3. Compare data and coding bugs?   
4. Differentiate testing and debugging?   
5. Explain complexity barrier?  

 

7.5 LAB ASSIGNMENT:  
 

1. Write test case for Library Application?   
2. Write test case for online shopping?   
3. Write test case for Google web search?  
4. Write test case for Android application?  
5. Write test case for ATM?  

 
7.6 POST LAB VIVA QUESTIONS:  
 

1. Write about design test cases?   
2. What are integration bugs?   
3. Define system bugs?   
4. What are design specifications?   
5. What is path testing?  



WEEK – 8 (A)  
8.1 OBJECTIVE:  
 

Create a test plan document for any application (e.g. Library Management System)  

 

8.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  
 

8.3 TEST PLAN DOCUMENT FOR LIBRARY MANAGEMENT SYSTEM:  

 
The Library Management System is an online application for assisting a librarian imagining book 
library in a University. The system would provide basic set of features to add/update clients, add/update 
books, search for books, and manage check-in / checkout processes. Our test group tested the system 
based on the requirement specification .This test report is the result for testing in the LMS. It mainly 
focuses on two problems 

 
1. What we will test   
2. How we will test.  

 

1. GUI test  
 

Pass criteria: librarians could use this GUI to interface with the backend library database 
 

without any difficulties. 
 

2. Database test 
 

Pass criteria: Results of all basic and advanced operations are normal (refer to section 4) 
 

3. Basic function test 

Add a student  
 

1. Each customer/student should have following attributes: Student ID/SSN (unique), Name, 

Address and Phone number.  
 

2. The retrieved customer information by viewing customer detail should contain the four at-

tributes.  
 

4. Update/delete student  
 

1. The record would be selected using the student ID.  
 

2. Updates can be made on full. Items only: Name, Address, Phone number .The record can be 

deleted if there are no books issued by user. The updated values would be reflected if the same 

customer's ID/SSN is called for.  
 

5. Check-in book  
 

1. Librarians can check in a book using its call number  
 

2. The check-in can be initiated from a previous search operation where user has selected a set 

of books.  
 

3. The return date would automatically reflect the current system date.  
 

4. Any late fees would be computed as difference between due date and return date at rate of 10 

cents a day.  



8.4 PRE LAB VIVA QUESTIONS:  

 
1. Difference between domain and path testing?  
2. What is testing blindness?  
3. What is path instrumentation?   
4. What are graph matrices?   
5. Define slice and dice?  

 

8.5 LAB ASSIGNMENT:  
 

1. Design test plan document for e-library?   
2. Design test plan document for credit card processing?   
3. Design test plan document for ticket vending machine?   
4. Design test plan document for Airport check-in business model?  
5. Design test plan document for school management system?  

 

8.6 POST LAB VIVA QUESTIONS:  
 

1. What are domain bugs?  
2. What is meant by predicate coverage?  

3. Define path sensitization?   
4. What C1, C2 Coverage?   
5. Define Link marks and Link counters?  



WEEK – 8 (B)  
8.1 OBJECTIVE:  

 
Study of Any Testing Tool( Win Runner)  

 
8.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 2K 

server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.  
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win  

95/98/NT/2K/XP, IE 5. 
 
8.3 STUDY OF WIN RUNNER TESTING TOOL:  

 
Win Runner is a program that is responsible for the automated testing of software.  

 
Win Runner is a Mercury Interactive enterprise functional testing tool for Microsoft windows 
applications.  

 

Importance of Automated Testing:  

 

Reduced testing time Consistent test procedures – ensure process repeatability and resource 
independence. Eliminates errors of manual testing. Reduces QA cost – Upfront cost of automated testing 
is easily recovered over the life-time of the product .Improved testing productivity – test suites can be 
run earlier and more often Proof of adequate testing .For doing Tedious work – test team members can 
focus on quality areas.  

 

Win Runner Uses:  

 
1. With Win Runner sophisticated automated tests can be created and run on an application. A series of 

wizards will be provided to the user, and these wizards can create tests in an automated manner.  
 

2. Another impressive aspect of Win Runner is the ability to record various interactions, and transform 
them into scripts. Win Runner is designed for testing graphical user interfaces. When the user make 
an interaction with the GUI, this interaction can be recorded. Re-cording the interactions allows 
determining various bugs that need to be fixed. When the test is completed, Win Runner will provide 
with detailed information regarding the results. It will show the errors that were found, and it will 
also give important information about them. The good news about these tests is that they can be 
reused many times.  

 
3. Win Runner will test the computer program in a way that is very similar to normal user interactions. 

This is important, because it ensures a high level of accuracy and realism. Even if an engineer is not 
physically present, the Recover manager will troubleshoot any problems that may occur, and this 
will allow the tests to be completed without errors.  

 
4. The Recover Manager is a powerful tool that can assist users with various scenarios. This is 

important, especially when important data needs to be recovered.  
 

5. The goal of Win Runner is to make sure business processes are properly carried out. Win Runner 
uses TSL, or Test Script Language.  

 
Win Runner Testing Modes 

 
Context Sensitive 

 
Context Sensitive mode records your actions on the application being tested in terms of the GUI objects 
you select (such as windows, lists, and buttons), while ignoring the physical location of the object on the 
screen. Every time you perform an operation on the application being tested, a TSL statement describing 
the object selected and the action performed is generated in the test script. As you record, Win Runner 
writes a unique description of each selected object to a GUI map. 

 
The GUI map consists of files maintained separately from your test scripts. If the user interface of your 
application changes, you have to update only the GUI map, instead of hundreds of tests. This allows you 
to easily reuse your Context Sensitive test scripts on future versions of your application. 

 
To run a test, you simply play back the test script. Win Runner emulates a user by moving the mouse 
pointer over your application, selecting objects, and entering keyboard input. Win Runner reads the 
object descriptions in the GUI map and then searches in the application being tested for objects 
matching these descriptions. It can locate objects in a window even if their placement has changed. 



Analog 

 
Analog mode records mouse clicks, keyboard input, and the exact x and y coordinates traveled by the 
mouse. When the test is run, Win Runner retraces the mouse tracks. Use Analog mode when exact 
mouse coordinates are important to your test, such as when testing a drawing application. 
 
The Win Runner Testing Process 
 
Testing with Win Runner involves six main stages: 
 
1. Create the GUI Map 

 
The first stage is to create the GUI map so Win Runner can recognize the GUI objects in the application 
being tested. Use the Rapid Test Script wizard to review the user interface of your application and 
systematically add descriptions of every GUI object to the GUI map. Alternatively, you can add 
descriptions of individual objects to the GUI map by clicking objects while recording a test. 
 
2. Create Tests 

 
Next is creation of test scripts by recording, programming, or a combination of both. While recording 
tests, insert checkpoints where we want to check the response of the application being tested. We can 
insert checkpoints that check GUI objects, bitmaps, and databases. During this process, Win Runner 
captures data and saves it as expected results the expected response of the application being tested. 
 
3. Debug Tests 

 
Run tests in Debug mode to make sure they run smoothly. One can set breakpoints, monitor variables, 
and control how tests are run to identify and isolate defects. Test results are saved in the debug folder, 
which can be discarded once debugging is finished. When Win Runner runs a test, it checks each script 
line for basic syntax errors, like incorrect syntax or missing elements in If, While, Switch, and For 
statements. We can use the Syntax Check options (Tools >Syntax Check) to check for these types of 
syntax errors before running your test. 
 
4. Run Tests 

 
Tests can be run in Verify mode to test the application. Each time Win Runner encounters a checkpoint 
in the test script, it compares the current data of the application being tested to the expected data 
captured earlier. If any mismatches are found, Win Runner captures them as actual results. 
 
5. View Results 

 
Following each test run, Win Runner displays the results in a report. The report details all the major 
events that occurred during the run, such as checkpoints, error messages, system messages, or user 
messages. If mismatches are detected at checkpoints during the test run, we can view the expected 
results and the actual results from the Test Results window. In cases of bitmap mismatches, one can also 
view a bitmap that displays only the difference between the expected and actual results. 

 
We can view results in the standard Win Runner report view or in the Unified report view. The Win 
Runner report view displays the test results in a Windows style viewer. The Unified report view displays 
the results in an HTML style viewer (identical to the style used for Quick Test Professional test results). 
 
6. Report Defects 

 
If a test run fails due to a defect in the application being tested, one can report information about the 
defect directly from the Test Results window .This information is sent via e-mail to the quality 
assurance manager, who tracks the defect until it is fixed. 
 
Using Win runner Window 
 
Before you begin creating tests, you should familiarize yourself with the Win Runner main window. 
 
To start Win Runner: 
 
Choose Programs>Win Runner>Win Runner on the Start menu. 



The first time you start Win Runner, the Welcome to Win Runner window and the What‗s New in Win  
Runner help open. From the Welcome window you can create a new test, open an existing test, or view 
an overview of Win Runner in your default browser. If you do not want this window to appear the next 
time you start Win Runner, clear the Show on Startup check box. To show the Welcome to Win 
Runner window upon startup from within Win Runner, choose Settings > General Options, click the 
Environment tab, and select the Show Welcome screen check box. 
 
The Main Win Runner Window 
 
The main Win Runner window contains the following key elements:  
1. Win Runner title bar   
2. Menu bar, with drop-down menus of Win Runner commands   
3. Standard toolbar, with buttons of commands commonly used when running a test   
4. User toolbar, with commands commonly used while creating a test  
 
5. Status bar, with information on the current command, the line number of the insertion point and the 

name of the current results folder  
 
6. The Standard toolbar provides easy access to frequently performed tasks, such as opening, 

executing, and saving tests, and viewing test results.  

 
Standard Toolbar 

 
The User toolbar displays the tools you frequently use to create test scripts. By default, the User toolbar 
is hidden. To display the User toolbar, choose Window>User Toolbar. When you create tests, you can 
minimize the Win Runner window and work exclusively from the toolbar. The User toolbar is 
customizable. You choose to add or remove buttons using the Settings > Customize User Toolbar menu 
option. When you reopen Win Runner, the User toolbar appears as it was when you last closed it. The 
commands on the Standard toolbar and the User toolbar are described in detail in subsequent lessons. 
 
Note that you can also execute many commands using soft keys. Sof keys are keyboard shortcuts for 
carrying out menu commands. You can configure the softkey combinations for your keyboard using the 
Softkey Configuration utility in your Win Runner program group. For more information, see the Win 
Runner at a Glance chapter in your Win Runner User‘s Guide. Now that you are familiar with the main  
Win Runner window, take a few minutes to explore these window components before proceeding to the 
next lesson. 
 
The Test Window 
You create and run Win Runner tests in the test window. It contains the following key elements: 
1. Test window title bar, with the name of the open test  
2. Test  script, with  statements generated by recording and/or  programming in TSL,  Mercury  

Interactive‗s Test Script Language.  
 
3. Execution arrow, which indicates the line of the test script being executed during a test run, or the 

line that will next run if you select the Run from arrow option  
4. Insertion point, which indicates where you can insert or edit text.  

 
Experiment-1 

 
Create a script by recording in Context Sensitive mode that tests the process of opening an order in the 
Flight Reservation application. You will create the script 
 

1. Start Win Runner. 
 

If Win Runner is not already open, choose Programs > Win Runner > Win Runner on the Start 
menu. 

 
2. Open a new test. 

 
If the Welcome window is open, click the New Test button. Otherwise, choose File > New. A new 
test window opens in Win Runner. 

 
3. Start the Flight Reservation application and log in. 

 
Choose Programs > Win Runner > Sample Applications > Flight 1A on the Start menu. In the 
Login window, type your name and the password mercury, and click OK. The name you type must 
be at least four characters long. Position the Flight Reservation application and Win Runner so that 
they are both clearly visible on your desktop. 



4.  Start recording in Context Sensitive mode. 
 

In Win Runner, choose Create > Record—Context Sensitive or click the Record button on the 
toolbar. From this point on, Win Runner records all mouse clicks and keyboard input. Note that the 
text, ―Rec‖ appears in blue above the recording button. This indicates that you are recording in 
Context Sensitive mode. The status bar also informs you of your current recording mode. 

 
5. Open order #3.  

 
In the Flight Reservation application, choose File > Open Order. In the Open Order dialog box, 
select the Order No. check box. Type 3 in the adjacent box, and click OK. Watch how Win Runner 
generates a test script in the test window as you work.  

 

6. Stop recording.   
In Win Runner, choose Create > Stop Recording or click the Stop button on the toolbar.  

 

7. Save the test.  
 

Choose File > Save or click the Save button on the toolbar. Save the test as lesson3 in a convenient 
location on your hard drive. Click Save to close the Save Test dialog box. Note that Win Runner 
saves the lesson3 test in the file system as a folder, and not as an individual file. This folder contains 
the test script and the results that are generated when you run the test. 

 
Output: Win Runner Test Results window is open and displays the test results. Conclusion: 
Recording in Context Sensitive mode is cleared and test results are also seen. 
 
Experiment -2 
 
Aim: Purpose of this exercise is to Study Synchronizing test 
 
Synchronizing test  
When you run tests, your application may not always respond to input with the same speed. 
For example, it might take a few seconds: 
1. To retrieve information from a database   
2. For a window to pop up   
3. For a progress bar to reach 100%   
4. For a status message to appear  

 
Win Runner waits a set time interval for an application to respond to input. The default wait interval is 
up to 10 seconds. If the application responds slowly during a test run, Win Runner‘s default wait time 
may not be sufficient, and the test run may unexpectedly fail. If you discover a synchronization problem 
between the test and your application, you can either: 
 
• Increase the default time that Win Runner waits. To do so, you change the value of the Timeout for 
Checkpoints and CS Statements option in the Run tab of the General Options dialog box(Settings > 
General Options). This method affects all your tests and slows down many other Context Sensitive 
operations. Insert a synchronization point into the test script at the exact point where the problem occurs. 
A synchronization point tells Win Runner to pause the test run in order to wait for a specified response 
in the application. This is the recommended method for synchronizing a test with your application. In 
the following exercises you will: 

 
1. Create a test that opens a new order in the Flight Reservation application and inserts the order into 

the database  
2. Change the synchronization settings   
3. Identify a synchronization problem   
4. Synchronize the test   
5. Run the synchronized test  

 
Input: 
 
Creating a Test 
 
In this first exercise you will create a test that opens a new order in the Flight Reservation application 
and inserts the order into a database. 
 
1. Start Win Runner and open a new test.  
 

If Win Runner is not already open, choose Programs > Win Runner > Win Runner on the Start 
menu. If the Welcome window is open, click the New Test button. Otherwise, choose File > New. 
A new test window opens. 



 
 
2. Start the Flight Reservation application and log in.  
 

Choose Programs > Win Runner > Sample Applications > Flight 1A on the Start menu. In the 
Login window, type your name and the password mercury, and click OK. Reposition the Flight 
Reservation application and Win Runner so that they are both clearly visible on your desktop. 

 
3. Start recording in Context Sensitive mode.  
 

Choose Create > Record Context Sensitive or click the Record button on the tool bar.Win 
Runner will start recording the test. 

 
4. Create a new order.   

Choose File > New Order in the Flight Reservation application.  

 

5. Fill in flight and passenger information.  

 

6. Insert the order into the database.  
 

Click the Insert Order button. When the insertion is complete, the ―Insert Done‖ message appears 
in the status bar. 

 
7. Delete the order.   

Click the Delete Order button and click Yes in the message window to confirm the deletion.  

 

8. Stop recording.   
Choose Create > Stop Recording or click the Stop button.  

 

9. Save the test.  
 

Choose File > Save. Save the test as lesson4 in a convenient location on your hard drive. Click 
Save to close the Save Test dialog box.  

 
Output: Win Runner Test Results window is open and displays the test results. 
 
Conclusion: Importance of Synchronizing test is cleared and test results are also seen. 
 
Experiment -3 

 
Aim: When working with an application, you can determine whether it is functioning 
properly according to the behavior of its GUI objects. 
 
Checking GUI Objects 
 
Input:  
Adding GUI Checkpoints to a Test Script 
 
In this exercise you will check that objects in the Flight Reservation Open Order dialog box 
function properly when you open an existing order. 
 
1. Start Win Runner and open a new test.  
 

If Win Runner is not already open, choose Programs > Win Runner > Win Runner on the Start 
menu. If the Welcome window is open, click the New Test button. Otherwise, choose File > New. 
A new test window opens.  

 
2 .Start the Flight Reservation application and log in. 
 

Choose Programs > Win Runner > Sample Applications > Flight 1A on the Start menu. In the 
Login window, type your name and the password mercury, and click OK. Reposition the Flight 
Reservation application and Win Runner so that they are both clearly visible on your desktop. 

 
3 Start recording in Context Sensitive mode.   

Choose Create > Record Context Sensitive or click the Record button on the toolbar.  

 

4 Open the Open Order dialog box.   
Choose File > Open Order in the Flight Reservation application.   

6. Create a GUI checkpoint for the Order No. check box.  



Choose Create > GUI Checkpoint > For Object/Window, or click the GUI Checkpoint for 
Object/Window button on the User toolbar .Use the pointer to double click the Order No. check 
box. The Check GUI dialog box opens and displays the available checks. Note that this dialog box 
does not open if you only single clicked the Order No. check box. Accept the default check, ―State.‖ 

 
This check captures the current state (off) of the check box and stores it as expected results. Click 
OK in the Check GUI dialog box to insert the checkpoint into the test script. The checkpoint 
appears as an obj check gui statement. 

 
7. Enter “4” as the Order No. 

Select the Order No. check box and type in 4 in the Order No. text box. 
 
8. Create another GUI checkpoint for the Order No. check box.  
 

Choose Create > GUI Checkpoint > For Object/Window or click the GUI Checkpoint for 
Object/Window button on the User toolbar. Use the pointer to single click the Order No. check box. 
Win Runner immediately inserts a checkpoint into the test script (an obj_check_gui statement) that 
checks the default check ―State.‖ (Use this shortcut when you want to use only the default check for 
an object.) This check captures the current state (on) of the check box and stores it as expected 
results.  

 

9. Create a GUI checkpoint for the Customer Name check box.  
 

Choose Create > GUI Checkpoint > For Object/Window or click the GUI Checkpoint for 
Object/Window button on the User toolbar. Use the pointer to double click the Customer Name 
check box. The Check GUI dialog box opens and displays the available checks. Accept the default 
check ―State‖ and select ―Enabled‖ as an additional check. The State check captures the current 
state (off) of the check box; the Enabled check captures the current condition (off) of the check box.  

 
Click OK in the Check GUI dialog box to insert the checkpoint into the test script. The checkpoint 
appears as an obj_check_gui statement.  

 

10. Click OK in the Open Order dialog box to open the order.  

 

11. Stop recording.  

Choose Create > Stop Recording or click the Stop button.  
12. Save the test.  

Choose File > Save or click the Save button. Save the test as lesson5 in a convenient location on 
your hard drive. Click Save to close the Save Test dialog box. 

 
13. If you are working in the Global GUI Map File mode, save the new objects to the GUI map. 

Choose Tools > GUI Map Editor. Choose View > GUI Files. Choose File > Save. Click Yes or 
OK to add the new object or new window to your GUI map. Choose File > Exit to close the GUI 
Map Editor.  

 
In Running the Test you will now run the lesson5 test in order to verify that the test runs smoothly. 
 
1. Make sure that the Flight Reservation application is open on your desktop.  

 

2. In Win Runner, check that Verify mode is selected in the Standard toolbar.  

 

3. Choose Run from Top.  

Choose Run > Run from Top, or click the Run from Top button. The Run Test dialog box opens.  
Accept the default test run name ―res1.‖ Make sure that the Display test results at end of run 
check box is selected. 

 
4. Run the test.  

Click OK in the Run Test dialog box.  

 

5. Review the results.   
When the test run is completed, the test results appear in the Win Runner Test Results window. In 
the test log section all ―end GUI checkpoint‖ events should appear in green (indicating 
success).Double click an end GUI checkpoint event to view detailed results of that GUI 
checkpoint. The GUI Checkpoint Results dialog box opens. Select Customer Name to display the 
dialog box as follows: 

 
Output: Win Runner Test Results window is open and displays the test results. 
 
Conclusion: Explains how to check the behavior of GUI objects and shows you how to create a test that 
checks GUI objects. 



Experiment -4 

 
Aim: Purpose of these exercises to study a bitmap checkpoint compares captured bitmap images pixel 
by pixel. 
 
Input:  
Checking Bitmap Objects 

 
Adding Bitmap Checkpoints to a Test Script 
 
In this exercise you will test the Agent Signature box in the Fax Order dialog boxYou will use a bitmap 
checkpoint to check that you can sign your name in the box then you will use another bitmap checkpoint 
to check that the box clears when you click the Clear Signature button. 
 
1. Start Win Runner and open a new test. 
 

If Win Runner is not already open, choose Programs > WinRunner > WinRunner on the Start menu. 
If the Welcome window is open, click the New Test button. Otherwise, choose File > New. A new 
test window opens. 

 
2. Start the Flight Reservation application and log in.  
 

Choose Programs > Win Runner > Sample Applications > Flight 1A on the Start menu. In the Login 
window, type your name and the password mercury, and click OK. Reposition the Flight Reservation 
application and Win Runner so that they are both clearly visible on your desktop.  

 

3. Start recording in Context Sensitive mode.  
Choose Create > Record—Context Sensitive or click the Record button on the toolbar.  

 

4. Open order #6.   
In the Flight Reservation application, choose File > Open Order. In the Open Order dialog box, 
select the Order No. check box and type ―6‖ in the adjacent box. Click OK to open the order. 

 
5. Open the Fax Order dialog box.  

Choose File > Fax Order.  

 

6. Enter a 10digit fax number in the Fax Number box.  
You do not need to type in parentheses or dashes.  

 

7. Move the Fax Order dialog box.  
Position the dialog box so that it least obscures the Flight Reservation window. 

 
8. Switch to Analog mode. 

Press F2 on your keyboard or click the Record button to switch to Analog mode. 
 
9. Sign your name in the Agent Signature box.  

 

10. Switch back to Context Sensitive mode.  
Press F2 on your keyboard or click the Record button to switch back to Context Sensitive mode.  

 

11. Insert a bitmap checkpoint that checks your signature.  
 

Choose Create > Bitmap Checkpoint > For Object/Window or click the Bitmap Checkpoint for 
Object/Window button on the User toolbar.Use the pointer to click the Agent Signature box. Win 
Runner captures the bitmap and inserts an obj_check_bitmap statement into the test script.  

 

12. Click the Clear Signature button.  
The signature is cleared from the Agent Signature box.  

 

13. Insert another bitmap checkpoint that checks the Agent Signature box.  
 

Choose Create > Bitmap Checkpoint > For Object/Window or click the Bitmap Checkpoint for 
Object/Window button on the User toolbar.Use the pointer to click the Agent Signature box. Win 
Runner captures a bitmap and inserts an obj_check_bitmap statement into the test script.  

 

14. Click the Cancel button on the Fax Order dialog box.  
 

15. Stop recording.  
Choose Create > Stop Recording or click the Stop button. 



16. Save the test.  
 

Choose File > Save or click the Save button. Save the test as lesson6 in a convenient location 
on your hard drive. Click Save to close the Save Test dialog box.  

 

17. If you are working in the Global GUI Map File mode, save the new objects to the GUI map.  
 

Choose Tools > GUI Map Editor. Choose View > GUI Files. Choose File >Save. Click yes or OK 
to add the new object or new window to your GUI map. Choose File > Exit to close the GUI Map 
Editor.  

 
Output: 
 
Viewing Expected Results 
You can now view the expected results of the test. 
 
1. Open the Win Runner Test Results window. 

Choose Tools > Test Results or click the Test Results button. The Test Results window opens. 
 
2. View the captured bitmaps.  

In the test log section, double click the first ―capture bitmap‖ event, or select it and click the Display 
button.Next, doubleclick the second ―capture bitmap‖ event, or select it and click the Display button. 

 
3. Close the Test Results window. 

Close the bitmaps and choose File > Exit to close the Test Results window. 

 
Conclusion: Bitmap checkpoint compares captured bitmap images captured bitmap images pixel by 
pixel. 
 
Experiment -5 

 
Aim: Purpose of these exercises to study shows you how to use the Data Driver Wizard to create a 
data driven test 
 
Input: 
 
Creating data driven test 
 
Converting Your Test to a Data Driven Test 
Start by opening the test you already created and using the Data Driver Wizard to parameterize the test. 
 
1. Create a new test from the lesson7 test. 
 

If WinRunner is not already open, choose Programs > WinRunner > WinRunner on the Start menu. 
If the Welcome window is open, click the Open Test button. Otherwise, choose File > Open and 
select the test you created previously. The test opens. Choose File > Save As and save the test as 
lesson8 in a convenient location on your hard drive. 

 
2. Run the Data Driver Wizard.  
 

Choose Tools > Data Driver Wizard. The Data Driver Wizard welcome window opens. Click Next to 
begin the parameterization process.  

 
3. Create a data table for the test.  
 

In the Use a new or existing Excel table box, type ―lesson8‖. The Data Driver Wizard creates an 
Excel table with this name and saves it the test folder.  

 

4. Assign a table variable name.  
 

Accept the default table variable name, ―table‖. At the beginning of a data driven test, the Excel data 
table you wish to use is assigned as the value of the table variable. Throughout the script, only the 
table variable name is used. This makes it easy for you to assign a different data table to the script at 
a later time without making changes throughout the script.  

 

5. Select global parameterization options.  
 

Select Add statements to create a data driven test. This adds TSL statements to the test that define the 
table variable name, open and close the data table, and run the appropriate script selection in a loop 
for each row in the data table.  

 
Select parameterize the test and choose the Line by line option. When you select Parameterize the 
test, you instruct Win Runner to find fixed values in recorded statements and selected checkpoints  



and to replace them with parameters. The Line by line option instructs the wizard to open a screen 
for each line of the selected test that can be parameterized so that you can choose whether or not to 
parameterize that line. Click Next. 

 
6. Select the data to parameterize.  

The first line byline screen opens. It refers to the Order Number radio button.  

 
Adding Data to the Data Table 
Now that you have parameterized your test, you are ready to add the data the parameterized test will use. 
 
1. Open the data table. 

Choose Tools > Data Table. The lesson8.xls table opens. Note that there is one column named 
―Order_Num‖, and that the first row in the column contains value ―4‖. 

 
2. Add data to the table. 

In rows 2, 3, 4, and 5 of the Order_Num column, enter the values, ―1‖, ―6‖, and ―10‖ respectively. 
 
3. Save and close the table.  

Click an empty cell and choose File > Save from the data table menu. Then choose File > Close 
to close the table.  

4. Save the test. 
Choose File > Save or click the Save button. Click Save to close the Save Test dialog box. 

 
Output: 
 
Review the results. 

 
When the test run is completed, the test results appear in the Win Runner Test Results window. Note 
that the tl_step event is listed five times and that the details for each iteration include the actual number 
of tickets, price and total cost that was checked. 
 
Conclusion: Use Data Driver Wizard to create a data driven test. 
 
Experiment -6 

 
Aim: Explains how the GUI map enables you to continue using your existing test scripts after the user 
interface changes in your application. 
 
Input: 
 
Maintaining test script 
 
Editing Object Descriptions in the GUI Map Suppose that in a new version of the Flight Reservation 
application, the Insert Order button is changed to an Insert button. In order to continue running tests that 
use the Insert Order button, you must edit the label in the button‘s physical description in the GUI map. 
You can change the physical description using regular expressions. 
 
1. Start Win Runner and open a new test.  
 

If Win Runner is not already open, choose Programs > Win Runner > Win Runner on the Start 
menu. If the Welcome window is open, click the New Test button. Otherwise, choose File > New. 
A new test window opens. If you are working in the GUI Map File per Test mode, open the lesson4 
test.  

 

2. Open the GUI Map Editor.  
 

Choose Tools > GUI Map Editor. The GUI Map Editor opens. Make sure that View > GUI Map is 
selected. The Windows/Object list displays the current contents of the GUI Map. (If you are 
working in the GUI Map File per Test Mode, the GUI Map Editor will contain fewer objects than as 
shown below).The GUI Map Editor displays the object names in a tree. Preceding each name is an 
icon representing the object‘s type. The objects are grouped according to the window in which they 
are located. You can double click a window icon to collapse or expand the view of its objects.  

 

3. Find the Insert Order button in the tree.  
 

In the GUI Map Editor, choose View > Collapse Objects Tree to view only the window titles.(If 
you are working in the GUI Map File per Test Mode, the GUI Map Editor will contain fewer 
objects than as shown below. Double click the Flight Reservation window to view its objects. If 
necessary, scroll down the alphabetical object list until you locate the Insert Order button.  



4. View the Insert Order button’s physical description.  
 

Click the Insert Order button in the tree. (If you are working in the GUI Map File per Test Mode, 
the GUI Map Editor will contain fewer objects than as shown below.)The physical description 
object is displayed in the bottom pane of the GUI Map Editor.  

 

5. Modify the Insert Order button’s physical description.   
Click the Modify button or double click the Insert Order button. The Modify dialog box opens and 
displays the button‘s logical name and physical description. In the Physical Description box, change 
the label property from Insert Order to Insert. Click OK to apply the change and close the dialog 
box. 

 
6. Close the GUI Map Editor.  
 

In the GUI Map Editor, choose File > Save to save your changes and then choose File > Exit. If 
you are working in the GUI Map File per Test Mode, choose File > Exit in the GUI Map Editor and 
then File > Save in Win Runner.  

 
The next time you run a test that contains the logical name ―Insert Order‖, WinRunner will locate 
the Insert button in the Flight Reservation window. If you are working in the GUI Map File per 
Test Mode, go back and perform steps1 through 6 for the lesson9 test. In practice, all maps 
containing the modified object/window must be changed.  

 
Adding GUI Objects to the GUI Map 

 
Note: If you are working in the GUI Map File per Test mode, skip this exercise,since new objects are 
saved in your test‘s GUI map automatically when you save your test.If your application contains new 
objects, you can add them to the GUI map without running the RapidTest Script wizard again. You 
simply use the Learn button in the GUI Map Editor to learn descriptions of the objects. You can learn 
the description of a single object or all the objects in a window. In this exercise you will add the objects 
in the Flight Reservation Login window to the GUI map. 
 
1. Open the Flight Reservation Login window.  
 

Choose Programs > Win Runner > Sample Applications > Flight 1A on the 
Start menu.  

 

2. Open the GUI map.  
In Win Runner, choose Tools > GUI Map Editor. The GUI Map Editor opens.  

 
3 Learn all the objects in the Login window.  

Click the Learn button. Use the pointer to click the title bar of the Login window. A message 
prompts you to learn all the objects in the window. Click Yes. Watch as Win Runner learns a 
description of each object in the Login window and adds it to the temporary GUI Map. 

 
4. Save the new objects in the GUI map.  

Choose Tools > GUI Map Editor. Choose View > GUI Files. Choose File >Save. Click Yes or  
OK to add the new object or new window to your GUI map. Choose File > Exit to close the GUI 
Map Editor. 5 Close the Login window. Click Cancel. 

 
Updating the Map with the Run GUI Wizard 

 
Note: If you are working in the GUI Map File per Test mode, skip this exercise,since new objects are 
automatically saved in your test‘s GUI map when you save your test.During a test run, if Win Runner 
cannot locate an object mentioned in the test script, the Run wizard opens. The Run wizard helps you 
update the GUI map so that your tests can run smoothly. It prompts you to point to the object in our 
application, determines why it could not find the object, and then offers a solution. In most cases the 
Run wizard will automatically modify the object description in the GUI map or add a new object 
description. 
 
For example, suppose you run a test that clicks the Insert Order button in the Flight Reservation 
window: button_press ("Insert Order"); If the Insert Order button is changed to an Insert button, the Run 
wizard opens during a test run and describes the problem.You click the hand button in the wizard and 
click the Insert button in the Flight Reservation program. The Run wizard then offers a solution: When 
you click OK, Win Runner automatically modifies the object‘s physical description in the GUI map and 
then resumes the test run. 



If you would like to see for yourself how the Run wizard works: 
 

1. Open the GUI map.  
a. Choose Tools > GUI Map Editor. Choose View > GUI Files.   

2. Delete the “Fly From” list object from the GUI Map Editor tree.  
 

a. The Fly From object is listed under the Flight Reservation window. Select this object and click the 
Delete button in the GUI Map Editor.   

3. Open Flight Reservation 1A.  
 

a. Choose Programs > Win Runner > Sample Applications > Flight 1A on the Start menu. In the 
Login window, type your name and the password mercury, and click OK. Reposition the Flight 
Reservation application and Win Runner so that they are both clearly visible on your desktop.   

4. In Win Runner, open the lesson4 test and run it.  
 

a. Watch what happens when WinRunner reaches the statement list_select_item ("Fly From:", "Los 
Angeles")   

5. Follow the Run wizard instructions.  
 

a. The Run wizard asks you to point to the Fly from object and then adds the object description to the 
GUI map. Win Runner then continues the test run.   

6. Find the object description in the GUI map.  
 

a. When Win Runner completes the test run, return to the GUI Map Editor and look for the Fly from 
object description. You can see that the Run wizard has added the object to the tree.   

7. Close the GUI Map.  
a. In the GUI Map Editor, choose File > Exit.   

8. Close the Flight Reservation application.  
a. Choose File > Exit.  

 
b. Conclusion: GUI map enables using existing test scripts after the user interface changes in 
application.  

 

 

8.4 PRE LAB VIVA QUESTIONS:  

 
1. Define win runner?   
2. Explain uses of win runner?   
3. What are different modes of win runner?   
4. Explain win runner testing process?   
5. How to test a module using win runner?  

 

8.5 LAB ASSIGNMENT:  
 

1. Create a script in win runner in context sensitive mode?   
2. What are the steps for synchronizing test in win runner?   
3. Generate test cases for library application using win runner?   
4. Generate test cases for online shopping?  
5. Generate test cases for bank application?  

 

8.6 POST LAB VIVA QUESTIONS:  

 
1. Define context sensitive mode?  

2. What is test script?   
3. What is data driver wizard?   
4. How to create test in win runner?   
5. How to debug test in win runner?  



WEEK – 9 (A) 
 
9.1 OBJECTIVE:  
 

Study of any web testing tool (e.g. Selenium)  
 
9.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  

 

9.3 STUDY OF SELENIUM WEB TESTING TOOL:  

 
1. Selenium is a robust set of tools that supports rapid development of test automation for web-based 

applications. Selenium provides a rich set of testing functions specifically geared to the needs of 
testing of a web application. These operations are highly flexible, allowing many options for 
locating UI elements and comparing expected test results against actual application behavior.  

 
2. One of Selenium‗s key features is the support for executing one‗s tests on multiple browser 

platforms.   
3. Selenium Components  

 
4. Selenium is composed of three major tools. Each one has a specific role in aiding the development 

of web application test automation.  

 
Selenium-RC provides an API (Application Programming Interface) and library for each of its supported 
languages: HTML, Java, C#, Perl, PHP, Python, and Ruby. This ability to use Selenium-RC with a high 
level programming language to develop test cases also allows the automated testing to be integrated with 
a project‗s automated build environment. 

 
Selenium-Grid 

 
Selenium-Grid allows the Selenium-RC solution to scale for large test suites or test suites that must be 

run in multiple environments. With Selenium-Grid, multiple instances of Selenium-RC are running on 
various operating system and browser configurations; Each of these when launching register with a hub. 
When tests are sent to the hub they are then redirected to an available Selenium-RC, which will launch 
the browser and run the test. This allows for running tests in parallel, with the entire test suite 
theoretically taking only as long to run as the longest individual test. 

 
1. Tests developed on Firefox via Selenium-IDE can be executed on any other supported browser via a 
simple Selenium-RC command line.  

 
2. Selenium-RC server can start any executable, but depending on browser security set-tings there may be 
technical limitations that would limit certain features.  

 
Flexibility and Extensibility 

 
Selenium is highly flexible. There are multiple ways in which one can add functionality to Selenium‗s 
framework to customize test automation for one‗s specific testing needs. This is, perhaps, Selenium‗s 
strongest characteristic when compared with proprietary test automation tools and other open source 
solutions. Selenium-RC support for multiple programming and scripting languages allows the test writer 
to build any logic they need into their automated testing and to use a preferred programming or scripting 
language of one‗s choice. 

 
Selenium-IDE allows for the addition of user-defined user extensions for creating additional commands 
customized to the user‗s needs. Also, it is possible to re-configure how the Selenium-IDE generates its 
Selenium-RC code. This allows users to customize the generated code to fit in with their own test 
frameworks. Finally, Selenium is an Open Source project where code can be modified and enhancements 
can be submitted for contribution. 

 
Test Suites 

 
A test suite is a collection of tests. Often one will run all the tests in a test suite as one continuous batch 
job. When using Selenium -IDE, test suites also can be defined using a simple HTML file. The syntax 
again is simple. An HTML table defines a list of tests where each row defines the file system path to each 
test. An example tells it all. 

 
<html>  
<head> 

 
<title>Test Suite Function Tests – Priority 1</title></head> 
<body> 
<table> 



<tr><td><b>Suite Of Tests</b></td></tr> 
<tr><td><a href=‖./Login.html‖>Login</a></td></tr>  
<tr><td><a href=‖./SearchValues.html‖>Test Searching for Values</a></td></tr> 
<tr><td><a href=‖./SaveValues.html‖>Test Save</a></td></tr> 
</table></body> 
</html> 

 
A file similar to this would allow running the tests all at once, one after another, from the Selenium-IDE. 

 
Test suites can also be maintained when using Selenium-RC. This is done via programming and can be 
done a number of ways. Commonly Junit is used to maintain a test suite if one is using Selenium-RC with 
Java. Additionally, if C# is the chosen language, Nunit could be employed. If using an interpreted 
language like Python with Selenium-RC than some simple programming would be involved in setting up 
a test suite. Since the whole reason for using Sel-RC is to make use of programming logic for your testing 
this usually isn‗t a problem. 

 
Few typical Selenium commands. 

 

 
1. open – opens a page using a URL.   
2. click/clickAndWait – performs a click operation, and optionally waits for a new page to load.  
3. verifyTitle/assertTitle – verifies an expected page title.  

4. verifyTextPresent – verifies expected text is somewhere on the page.  
 

5. verifyElementPresent – verifies an expected UI element, as defined by its HTML tag, is present on 
the page.   

6. verifyText – verifies expected text and it‗s corresponding HTML tag are present on the page.  
7. verifyTable – verifies a table‗s expected contents.  

 
8. waitForPageToLoad – pauses execution until an expected new page loads. Called automatically 

when clickAndWait is used.  
 

9. waitForElementPresent – pauses execution until an expected UI element, as defined by its HTML 
tag, is present on the page.  

 

 

9.4 PRE LAB VIVA QUESTIONS:  

 
1. Explain about selenium tool?   
2. Compare win runner and selenium tool?   
3. What are the components of selenium tool?   
4. What are test suits for selenium tool?   
5. Define selenium grid?  

 

9.5 LAB ASSIGNMENT:  
 

1. Generate test cases using selenium tool for library application?   
2. Generate test cases using selenium tool for online shopping?   
3. Generate test cases using selenium tool for bank application?   
4. Generate test cases using selenium tool for ATM application?   
5. Generate test cases using selenium tool for Google advance search?  

 
9.6 POST LAB VIVA QUESTIONS:  
 

1. Define selenium IDE?   
2. What is an html file?   
3. Define the use of html file in selenium tool?   
4. What are the features of selenium tool?   
5. What is selenium RC code?  



WEEK – 9 (B) 
 
9.1 OBJECTIVE:   

Study of Any Bug Tracking Tool (Bugzilla)  
 
9.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 2K 

server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  
 

9.3 STUDY OF BUGZILLA,BUGBIT AND BUG TRACKING TOOL:  

 
Bugzilla is a Bug Tracking System that can efficiently keep track of outstanding bugs in a product. 
Multiple users can access this database and query, add and manage these bugs. Bugzilla essentially 
comes to the rescue of a group of people working together on a product as it enables them to view current 
bugs and make contributions to resolve issues. Its basic repository nature works out better than the 
mailing list concept and an organized database is always easier to work with.  

 

Advantage of Using Bugzilla:  

 

1. Bugzilla is very adaptable to various situations. Known uses currently include IT support queues, 
Systems Administration deployment management, chip design and development problem tracking (both 
pre-and-post fabrication), and software and hardware bug tracking for luminaries such as Redhat, NASA, 
Linux-Mandrake, and VA Systems. Combined with systems such as CVS, Bugzilla provides a powerful,  
easy to use solution to configuration management and replication problems. 

 
2. Bugzilla can dramatically increase the productivity and accountability of individual employees by 
providing a documented workflow and positive feedback for good performance. Ultimately, Bugzilla puts  
the power in user‗s hands to improve value to business while providing a usable framework for 
natural attention to detail and knowledge store to flourish. 

 
The bugzilla utility basically allows to do the following:  
1. Add a bug into the database  
2. Review existing bug reports   
3. Manage the content  

 
Bugzilla is organized in the form of bug reports that give all the information needed about a particular 
bug. A bug report would consist of the following fields. 

 
1. Product–>Component   
2. Assigned to  
3. Status (New, Assigned, Fixed etc)  

4. Summary   
5. Bug priority  
6. Bug severity (blocker, trivial etc)  
7. Bug reporter  

 
Using Bugzilla: 

 
Bugzilla usage involves the following activities 
Setting Parameters and Default Preferences 

 
1. Creating a New User  
2. Impersonating a User   
3. Adding Products   
4. Adding Product Components  
5. Modifying Default Field Values  

6. Creating a New Bug   
7. Viewing Bug Reports  



Setting Parameters and Default Preferences: 
 
When we start using Bugzilla, we‗ll need to set a small number of parameters and preferences. At a 
minimum, we should change the following items, to suit our particular need: 
1. Set the maintainer  
2. Set the mail_delivery_method   
3. Set bug change policies   
4. Set the display order of bug reports  

 
To set parameters and default preferences: 

 
1. Click Parameters at the bottom of the page.   
2. Under Required Settings, add an email address in the maintainer field.   
3. Click Save Changes.   
4. In the left side Index list, click Email.  
 
5. Select from the list of mail transports to match the transport we‗re using. If evaluating a click2try 

application, select test. If using SMTP, set any of the other SMTP options for your environment. 
Click Save Changes.   

6. In the left side Index list, click Bug Change Policies.  
 
7. Select On for comment on create, which will force anyone who enters a new bug to enter a comment, 

to describe the bug. Click Save Changes.   
8. Click Default Preferences at the bottom of the page.  
 
9. Select the display order from the drop-down list next to the When viewing a bug, show comments in 

this order field. Click Submit Changes.  

 
Creating a New User 

 
Before entering bugs, make sure we add some new users. We can enter users very easily, with a minimum 
of information. Bugzilla uses the email address as the user ID, because users are frequently notified when 
a bug is entered, either because they entered the bug, because the bug is assigned to them, or because 
they‗ve chosen to track bugs in a certain project. 
 
To create a new user:  
1. Click users.  
2. Click adds a new user.   
3. Enter the login name, in the form of an email address.   
4. Enter the real name, a password, and then click add.  
 
5. Select the group access options. We‗ll probably want to enable the following options in the row 

titled user is a member of these groups:   
6. Can confirm  
7. Edit bugs   
8. Edit components  

9. Click update when done with setting options.  

 
Impersonating a User 

 
Impersonating a user is possible, though rare, that we may need to file or manage a bug in an area that is 
the responsibility of another user when that user is not available. Perhaps the user is on vacation, or is 
temporarily assigned to another project. We can impersonate the user to create or manage bugs that 
belong to that user. 
 
Adding Products 
 
We‗ll add a product in Bugzilla for every product we are developing. To start with, when we first login to 
Bugzilla, we‗ll find a test product called TestProduct. We should delete this and create a new product. 
 
To add a product: 
1. At the bottom of the page, click Products.   
2. In the TestProduct listing, click Delete.   
3. Click Yes, Delete.   
4. Now click Add a product.   
5. Enter a product name, such as Widget Design Kit.   
6. Enter a description.   
7. Click Add. A message appears that you‗ll need to add at least one component.  



Adding Product Components 

 
Products are comprised of components. Software products, in particular, are typically made up of many 
functional components, which in turn are made up of program elements, like classes and functions. It‗s 
not unusual in a software development team environment for different individuals to be responsible for 
the bugs that are reported against a given component. Even if there are other programmers working on 
that component, it‗s not uncommon for one person, either a project lead or manager, to be the gatekeeper 
for bugs. Often, they will review the bugs as they are reported, in order to redirect them to the appropriate 
developer or even another team, to review the priority and severity supplied by the reporter, and 
sometimes to reject bugs as duplicates or enhancement requests, for example. 

 
To add a component: 
 
1. Click the link add at least one component in the message that appears after creating a new product.  
2. Enter the Component name.  

3. Enter a Description.  
 
4. Enter a default assignee. Use one of the users we‗ve created. Remember to enter the as signee in the 

form of an email address.  
5. Click Add.  
 
6. To add more components, click the name of product in the message that reads edit other components 

of product <product name>.  

 
Modifying Default Field Values 
 
Once we begin to enter new bugs, we‗ll see a number of drop down lists containing default values. Some 
of these may work just fine for our product. Others may not. We can modify the values of these fields, 
adding new values and deleting old ones. Let‗s take a look at the OS category. 
 
To modify default field values: 
 

1. At the bottom of the page, in the Edit section, click Field Values.  
 

2. Click the link, in this case OS, for the field we want to edit. The OS field contains a list of operating 
system names. We are going to add browsers to this list. In reality, we might create a custom field 
instead, but for the sake of this example, just add them to the OS list.   

3. Click Add a value. In the Value field, enter IE7.Click Add.   
4. Click Add a value again.   
5. In the Value field, enter Firefox 3.   
6. Click Add.   
7. Where it reads add other values for the op_sys field, click op_sys.  

 
8. This redisplays the table. We should now see the two new entries at the top of the table. These 

values will also appear in the OS drop down list when we create a new bug.  

 
Creating a New Bug 
 
Creating bugs is a big part of what Bugzilla does best. 
 
To create a new bug:  
1. In the top menu, click New.   
2. If we‗ve defined more than one component, choose the component from the component list.  
 
3. Select a Severity and a Priority. Severity is self explanatory, but Priority is generally assumed to be 

the lower the number, the higher the priority. So, a P1 is the highest priority bug, a showstopper.   
4. Click the OS dropdown list to see the options, including the new browser names we entered.  
5. Select one of the options.  
 
6. Enter a summary and a description. We can add any other information of choice, but it is not required 

by the system, although we may determine that our bug reporting policy requires certain information.   
7. Click Commit. Bugzilla adds our bug report to the database and displays the detail page for that bug.  

 
Viewing Bug Reports 

 
Eventually, we‗ll end up with thousands of bugs listed in the system. There are several ways to view the 
bugs. The easiest is to click the My Bugs link at the bottom of the page. Because we‗ve only got one bug 
reported, we‗ll use the standard Search function. 



To find a bug: 

 
1. Click Reports.  

 
2. Click the Search link on the page, not the one in the top menu. This opens a page titled Find a Specific 

Bug.   
3. Select the Status.   
4. Select the Product.  
5. Enter a word that might be in the title of the bug.  

 
6. Click Search. If any bugs meet the criteria that we have entered, Bugzilla displays them in a list 

summary.  
7. Click the ID number link to view the full bug report.  

 
Modifying Bug Reports  
Suppose we want to change the status of the bug. We‗ve reviewed it and have determined that it belongs 
to one of the users we have created earlier. 

 
To modify a bug report: 
1. Scroll down the full bug description and enter a comment in the Additional Comments field.  

 
2. Select Reassign bug to and replace the default user ID with one of the other user IDs you created. It 

must be in the format of an email address.  
 
9.4 PRE LAB VIVA QUESTIONS:  

 
1. Define bug tracking system?   
2. Compare hardware and software bug tracking system?  

3. What are the uses of Bugzilla?   
4. What are the different setting parameters and default preferences?   
5. Explain how to design test cases using bug bit?  

 

9.5 LAB ASSIGNMENT:  
 

1. Generate and apply Bugzilla bug tracking to android application?   
2. Generate and apply Bugzilla bug tracking to library application?  
3. Generate and apply Bugzilla bug tracking to bank system?  

4. Generate and apply bug bit bug tracking to ATM?   
5. Generate and apply bug bit bug tracking to Google web search application?  

 
9.6 POST LAB VIVA QUESTIONS:  

 
1. How to add components in Bugzilla?   
2. How to add default field values in Bugzilla?   
3. How to add new bug in Bugzilla?   
4. How to add view bug reports in Bugzilla?   
5. How to add modify bug reports in Bugzilla?  



WEEK – 9 (C)  
9.1 OBJECTIVE:  
 

Study of Any Test Management Tool (Test Director) 
 
9.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 

2K server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.   
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win 

95/98/NT/2K/XP, IE 5.  
 
9.3 STUDY OF TEST DIRECTOR AND TEST MANAGEMENT TOOL:  

 
Test Director is a global test management solution which provides communication, organization, 
documentation and structure to the testing project.  

 

Test Director is used for  

 

1. Mapping Requirements to User acceptance test cases   
2. Test Planning by placing all the test cases and scripts in it.   
3. Manual testing by defining test steps and procedures   
4. Test Execution status   
5. Defect Management  

 
The Test Director Testing Process 

 
Test Director offers an organized framework for testing applications before they are deployed. Since test 
plans evolve with new or modified application requirements, you need a central data repository for 
organizing and managing the testing process. TestDirector guides through the requirements 
specification, test planning, test execution, and defect tracking phases of the testing process. The Test 
Director testing process includes four phases: 

 
Specifying Requirements 

 
1. Requirements are linked to tests and defects to provide complete traceability and aid the decision-

making process   
2. See what percent of requirements are covered by tests  

 
3. Each requirement in the tree is described in detail, and can include any relevant attachments. The QA 

tester assigns the requirement a priority level which is taken into consideration when the test team 
creates the test plan   

4. Import from Microsoft Word or third party RM tool  

 
Planning Tests  
1. The Test Plan Manager enables to divide application according to functionality. Application can be 

divided into units, or subjects, by creating a test plan tree.   
2. Define subjects according to:  

 
 Application functionality-such as editing, file operations, and reporting 


 






Type of testing-such as functional, user interface, performance, and load 


 
3. As the tests are also linked to defects, this helps ensure compliance with testing requirements 

throughout the testing process.  
 
 

Running Tests 
 

As the application constantly changes, using test lab, run manual and automated tests in the 
project in order to locate defects and assess quality. 

 
1. By creating test sets and choosing which tests to include in each set, test suite can be created? A test 

set is a group of tests in a Test Director Project database designed to achieve specific testing goals.  

 

2. Tests can be run manually or scheduled to run automatically based on application dependencies.  



Tracking Defects 

 
Locating and repairing application defects efficiently is essential to the testing process. Defects can be 
detected and added during all stages of the testing process. In this phase you per-form the following 
tasks: 

 
1. This tool features a sophisticated mechanism for tracking software defects, enabling Testing Team 

and the project Team to monitor defects closely from initial detection until resolution  

 
2. By linking Test Director to e-mail system, defect tracking information can be shared by all 

Development and Management Teams, Testing and Wipro Software Quality Assurance personnel  

 
System Requirements for Test Director 

 
Server System configuration : 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 2K 
server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL  
Server Client System con-figuration : 64 MB of RAM , 10 MB of free disk space, 
Win 95/98/NT/2K/XP, IE 5 , Netscape 4.7 

 
9.4 PRE LAB VIVA QUESTIONS:  
 

1. Define test director?   
2. What are the uses of test director?  

3. What is testing process for test director?  
4. What are the specification requirements for test director?  

5. What are the test plans for test director?  

 
9.5 LAB ASSIGNMENT:  

 
1. Generate test cases using test director for web application?   
2. Generate test cases using test director for online shopping?   
3. Generate test cases using test director for ATM?   
4. Generate test cases using test director for library application?   
5. Generate test cases using test director for hospital management system?  

 

9.6 POST LAB VIVA QUESTIONS:  
 

1. Can we link test director to email system?   
2. How can we track defects using test director?   
3. Define defect management?   
4. Explain test planning in test cases and scripts?  

5. What is meant by global test management?  



WEEK – 10  
10.1 OBJECTIVE:  
 

Study of any open source testing tool (Test Link)  

 

10.2 RESOURCES:  

 
1. Server System configuration: 128 MB of RAM , 500 MB of free disk space, Win NT server, Win 2K 

server, IIS 5.0, MS Access/Oracle 7.x,8.x,9/MS SQL.  
2. Server Client System configuration: 64 MB of RAM , 10 MB of free disk space, Win  

95/98/NT/2K/XP, IE 5. 
 
10.3 STUDY OF TEST LINK OPEN SOURCE TESTING TOOL: 

 
Test link is an open source test management tool. It enables creation and organization of test cases and 
helps manage into test plan. Allows execution of test cases from test link itself. One can easily track test 
results dynamically, generate reports, generate test metrics, prioritize test cases and assign unfinished 
tasks. It‘s a web based tool with GUI, which provides an ease to develop test cases, organize test cases 
into test plans, execute these test cases and generate re-ports. Test link exposes API, written in PHP, can 
help generate quality assurance dashboards. The functions like AddTestCase ToTestPlan, 

 
Assign Requirements, Create Test Case etc. helps create and organize test cases per test plan. Functions 
like GetTestCasesForTestPlan, GetLastExecutionResult allows one to create quality assurance 
dashboard. TestLink enables easily to create and manage Test cases as well as organize them into Test 
plans. These Test plans allow team members to execute Test cases and track test results dynamically, 
generate reports, trace software requirements, prioritize and assign tasks. Read more about implemented 
features and try demo pages. 

 
Overall structure 

 
There are three cornerstones: Product, Test Plan and User. All other data are relations or attributes for 
this base. First, definition of a couple of terms that are used throughout the documentation. 

 
Products and Test Plans 

 
1. Product: A Product is something that will exist forever in TestLink. Products will under-go many 
different versions throughout their lifetimes. Product includes Test Specification with Test Cases 
and should be sorted via Keywords.  

 
2. Test Plan: Test Plans are created when you‗d like to execute test cases. Test plans can be made up 
of the test cases of one or many Products. Test Plan includes Builds, Test Case Suite and Test Results.  

 
3. User: A User has a Role that defines available Test Link features.  

 
Test Case Categorization 

 
TestLink breaks down the test case structure into three levels Components, Categories, and test 
cases. These levels are persisted throughout the application. 

 
1. Component: Components are the parents of Categories. Each Component can have many   
2. Categories.   
3. Category: Categories are the parents of test cases. Each Category can have many test cases.   
4. Test Case: Test cases are the fundamental piece of TestLink.   
5. Test Specification: All Components, Categories and test cases within Product.   
6. Test Case Suite: All Components, Categories and test cases within Test Plan.  

 
Test Specification 

 
Creating Test Cases 

 
Tester must follow this structure: Component, Category and test case. At first you create Component(s) for 
your Product. Component includes Categories. Category has the similar meaning but is second level of 
Test Specification and includes just Test Cases.User can also copy or move Test Cases. 
Test Cases have following parts: 



1. Title: could include either short description or abbreviation (e.g. TL-USER-LOGIN)   
2. Summary: should be really short; just for overview.  
 
3. Steps: describe test scenario (input actions); can also include precondition and cleanup information 

here.  
4. Expected results: describe checkpoints and expected behavior a tested Product or system.  

 
Deleting Test Cases 

 
Test cases, Categories, and Components may be deleted from a test plan by users with lead permissions 
from the delete test cases screen. Deleting data may be useful when first creating a test plan since there are 
no results. However, Deleting test cases will cause the loss of all results associated with them. Therefore, 
extreme caution is recommended when using this functionality. 
 
Requirements relation 

 
Test cases could be related with software/system requirements as n to n. The functionality must be 
enabled for a Product. User can assign Test Cases and Requirements via link Assign Requirements in 
the main screen. 
 
Test Plans 

 
Test plan contains name, description, collection a chosen test cases, builds, test results, 
milestones, tester assignment and priority definition. 
 
Creating a new Test Plan 

 
Test Plans may be deleted from the Create test plan page (link Create Test Plan) by users with lead privileges. 
Test plans are the basis for test case execution. Test plans are made up of test cases imported from Products at a 
specific point of time. Test plans can only be created by users with lead privileges. Test plans may be created 
from other test plans. This allows users to create test plans from test cases that at a desired point in time. This 
may be necessary when creating a test plan for a patch. In order for a user to see a test plan they must have the 
proper rights. Rights may be assigned (by leads) in the define User/Project 
 
Rights section. This is an important thing to remember when users tell you they can‗t see the project they 
are working on. 
 
Test Execution 
 
Test execution is available when:  
1. A Test Specification is written.   
2. A Test Plan is created.   
3. Test Case Suite (for the Test Plan) is defined.   
4. A Build is created.   
5. The Test plan is assigned to testers (otherwise they cannot navigate to this Test Plan).  
 
6. Select a required Test Plan in main page and navigate to the Execute test link. Left pane serves 
for navigation in Test Case Suite via tree menu, filtering and define a tested build.  

 
Test Status 

 
Execution is the process of assigning a result (pass, fail, blocked) to a test case for a specific build. 
Blocked‗test case is not possible to test for some reason (e.g. a problem in configuration disallows to 
run a tested functionality). 
 
Insert Test results 

 
Test Results screen is shown via click on an appropriate Component, Category or test case in navigation 
pane. The title shows the current build and owner. The colored bar indicate status of the test case. 
Yellow box includes test scenario of the test case. 

 
Updated Test Cases: If users have the proper rights they can go to the Update modified testcase page 
through the link on main page. It is not necessary for users to update test cases if there has been a 
change (newer version or deleted). 



Advantages: 
 

1. Easy in tracking test cases(search with keyword, test case id, version etc)  
2. We can add our custom fields to test cases.  
3. Allocating the work either test case creation/execution any kind of documents is easy  
4. when a test cases is updated the previous version also can be tracked   
5. We can generate results build wise   
6. Test plans are created for builds and work allocations can be done.  

 
Report, is one of the awesome functionality present in the Test link, it generates reports in desired 
format like HTML/ CSV /Excel and we can create graphs too. And the above all is done on the 
privileges based which is an art of the testlink and i liked this feature much 

 
Example of TestLink workflow: 

 
1. Administrator create a Product Fast Food‖ and a user Adam with rights leader and Bela with rights 

Senior tester.   
2. Adam imports Software Requirements and for part of these requirements generates empty Test cases.  

 
3. Bela describe test scenario of these Test cases that are organized according to Components and 

Categories.  
4. Adam creates Keyword: Regression‖ and assigns this keyword to ten of these test cases.  
5. Adam creates a Test Plan Fish & Chips, Build Fish 0.1 and add Test Cases with keywords Regression.   
6. Adam and Bela execute and record the testing with result: 5 passed, 1 failed and 4 are blocked.  

 
7. Developers make a new build Fish 0.2 and Bela tests the failed and blocked test cases 

only. Exceptionally all these five Test cases passed.  
 

8. Manager would like to see results. Administrator explains him that he can create account himself on 
the login page. Manager does it. He has Guestrights and could see results and Test cases. He can see 
that everything passed in overall report and problems in build Fish 0.1 in a report for particular Build. 
But he can change nothing.  

 

10.4 PRE LAB VIVA QUESTIONS:  

 
1. Define test link?   
2. Difference between product and test plan?   
3. Explain test case categorization?  
4. What is test case specification?   
5. How to delete test case in Test Link?  

 
10.5 LAB ASSIGNMENT:  

 
1. Generate test cases for library application using Test Link?   
2. Generate test cases for ATM application using Test Link?   
3. Generate test cases for bank application using Test Link?   
4. Generate test cases for online shopping using Test Link?  
5. Generate test cases for online credit card processing using Test Link?  

 

10.6 POST LAB VIVA QUESTIONS:  

 
1. When a test execution is available in Test Link?  
2. Explain about test status   
3. What are the advantages of Test Link?   
4. How to create test cases in Test Link?   
5. Difference between Test Link and other test techniques?  

 
Testing helps is verifying and Validating if the Software is working as it is intended to be working. 
This involves using Static and Dynamic methodologies to Test the application. 
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VIVA QUESTIONS 

 
1. Define Object Oriented Analysis? Object Oriented Analysis (OOA) is a method of analysis that examines 

requirements from the perspective of the classes and objects found in the vocabulary of the problem 
domain?  

 
2. What is meant by Object Oriented? Object Oriented means we organize the software as a collection of 

discrete objects that incorporate both data structure and behavior?   
3. Write the characteristics of an object. Identity, classification, polymorphism, and inheritance?   
4. What is a class? A class is a set of objects that share a common structure and a common behavior?   
5. Name two types of object diagram. Class diagram and instance diagram?  
 
6. What is an attribute? Give example. An attribute is a data value held by the objects in a class .Example: 

name, age and weight are attributes of Person class?  
 
7. What is multiple inheritance? When one class inherits its state (attributes) and behavior from more than one 

super class, it is referred to as multiple inheritance?  
 
8. What is dynamic binding? The process of determining (dynamically) at run time which functions to invoke 

is termed dynamic binding?  
 
9. What is static binding? The process of determining at compile time which functions to invoke is termed 

static binding?  
 
10. Write the four quality measures for software development? Correspondence, correctness, verification, and 

validation?  
 
11. What is object persistence? Objects have life time. They are created and can exist for a period of time. A 

file or a database can provide support for objects having a longer life time longer than the duration of the 
process for which they were created. This characteristic is called object persistence?  

 
12. What is polymorphism? Give an example. Polymorphism means that the same operation may behave 

differently on different classes. Ex. Move operation. (Behave differently on the window class and chess 
Piece class)?  

 
13. What is cardinality? Cardinality specifies how many instances of one class may relate to a single instance of 

an associated class?  
 
14. What is a formal class or abstract class? Formal or abstract classes have no instances but define the 

common behaviors that can be inherited by more specific classes?  
 
15. What is a meta-class? A metaclass is a class about a class. They are normally used to provide instance 

variables and operations?  
 
16. Define Encapsulation? Encapsulation is the process of compartmentalizing the elements of an abstraction 

that constitute its structure and behavior?  
 
17. What is the need of an Object diagram? An object diagram is used to show the existence of objects and 

their relationships in the logical design of a system?  
 
18. What is state of an object? The state of an object encompasses all of the properties of the object plus the 

current values of each of these properties?  
 
19. Write some applications of object model? They include Air traffic control, Animation, Avionics, Database, 

Robotics etc.?  
 
20. Define Concurrency. Concurrency is the property that distinguishes an active object from one that is not 

active?  
 
21. Name the three general approaches for classification? They are Classical categorization, Conceptual 

clustering and Prototype theory?  
 
22. Name the five levels of process maturity in OOD? They are Initial, Repeatable, Defined, Managed and 

Optimized?  
 
23. Name the two process used by Grady BOOCH in his OO software development? They are Macro and 

Micro development process?  
 
24. Name the four steps in Micro development process? They are Identify the classes and objects, Give 

semantics to the classes, Identify class and object relationships, Identify class and object interfaces and 
implementation?  

 
25. What are the steps followed in macro development process? Conceptualization, analysis and development 

of the model, Design or create the system architecture, evolution or implementation, maintenance?  
 
26. Short notes on OMT functional model. OMT functional model uses dataflow diagram that shows the flow 

of data between different processes in a business .Data flow diagrams use four primary symbols. They are 
process, data flow, data store, external entity?  



27. Names the diagrams of Booch Methodology. Class diagram, object diagram, state transition diagram, 
module diagram, process diagram, interaction diagram?  

 
28. Name the models in objectory. Use case model, domain object model, analysis object model, 

implementation model, test model?  
 
29. What is unified modeling language? Unified modeling language is a language for specifying, conducting, 

visualizing and documenting the software system and its components?  
 
30. Name the available layers of the three layered approach to software development. Business layer, access 

layer, view (user interface) layer?   
31. Write the two responsibilities of access layer? Translate Request, Translate result?  
 
32. Write any two advantages of modeling? The main reason for modeling is the reduction of complexity. The 

cost of the modeling analysis is much lower than the cost of similar experimentation conducted with real 
time?  

 
33. What is Objectory? Objectory is a method or object-oriented development with the specific aim to fit the 

development of large, real-time systems?  
 
34. Define Static model? It can be viewed as a snapshot of a system‘s parameters at rest or a specific point in 

time. They are needed to represent the structural or static aspect of a system?  
 
35. Define Dynamic model? It can be viewed as a collection of procedures or behaviors that taken together 

reflect the behavior of a system over time. Dynamic modeling is the most useful during the design and 
implementation phases of the system development?  

 
36. What is an association? Give one example. An association is the relationship between the classes. Ex 

person and company are the classes, works-for is the association name. Works- for?  
 
37. What is a qualifier? Give one example. A qualifier is an association attribute. The qualifier rectangle is part 

of the association path, not part of the class. Give one example?   
38. What is a method? A method is the implementation of an operation for a class?  
 
39. What is a use case? Use cases are scenarios for understanding system requirements. A use case is an 

interaction between users and a system?   
40. Name the three types of relationships in a use case diagram. Communication, Uses, extends?   
41. Write the two types of Implementation diagram? Component diagram, deployment diagram?  
 
42. What is an activity? An activity is a set of operations that is executing during the entire period an object is 

in a state?  
 
43. Write the guidelines for preparing the Documentation. Common cover, 80-20 rule, Familiar vocabulary, 

makes the document as short as possible, organize the document. Bank Account Person Company Person?   
44. Name the types of relationships among the objects. Association, super-sub structure, aggregation?  
 
45. Write the guidelines for identifying the associations a dependency between two or more classes may be 

association a reference from one class to another is an association?   
46. Name the two properties of a part of relationship. Transitivity, Anti symmetry?   
47. Write the Guidelines for identifying part of relationship. Assembly, container, collection member?  
 
48. Define Prototype? A prototype is a version of a software product developed in the early stages of the 

product‘s life cycle for specific, experimental purposes. A prototype enables you to fully understand how 
easy or difficult it will be to implement some of the features of the system?  

 
49. Define pattern mining? The process of looking for patterns to document is called pattern mining sometimes 

called reverse architecture?  
 
50. Define anti-patterns? An anti-pattern represents a worst practice while a pattern represents a best Practice. 

Anti-patterns come in two varieties. Those describing a bad solution to a problem that resulted in a bad 
situation and those describing how to get out of a bad situation?  

 
51. Define patterns template? Every pattern must be expressed in the form of a rule which is called as a 

Template. It should establish a relationship between a context, a system of forces which arises in the 
context, and a configuration?  

 
52. Define proto-patterns? If something appears to have all the requisite pattern components, it should not be 

considered a pattern until it has been verified to be a recurring phenomenon .A proto-pattern is the ―pattern 
in waiting‖ which is not yet known to recur?   

53. Name the two categories of Quality assurance testing. Error based testing, scenario based testing?  
 
54. Define debugging. Debugging is the process of finding out where something went wrong and correcting the 

code to eliminate the errors or bugs that cause unexpected results?   
55. Write the two types of path testing. Statement testing coverage and Branch testing coverage?  
 
56. What is a meta-model? A meta-model is a model of modeling elements. UML graphic notations can be 

used not only to describe the system‘s components but also to describe a model itself?  



57. Define a Framework? A frame work is a collection of classes that provide a set of services for a particular 
domain?  

 
58. Write the differences between design patterns and frameworks Design patterns are more abstract than 

frameworks. Design patterns are smaller architectural elements than frameworks. Design patterns are less 
specialized than frameworks?  

 
59. Define SQA? SQA stands for Software Quality Assurance. This is the measure of assuring the quality of 

the software products. The major activity done here is testing. The assurance process also follows the 
quality model called the QAIMODEL (Quality Assurance Institute Model)?   

60. What is V Testing? ‗V‘ testing stands for Verification and Validation testing?   
61. What is a quality? Quality refers to the ability of products to meet the user‘s needs and expectations?  
 
62. Name the two issues for software quality. Validation or user satisfaction, and verification or quality 

assurance?  
 
63. Define user satisfaction testing. User satisfaction testing is the process of quantifying the usability test with 

some measurable attributes of the test, such as functionality, cost or ease of use?  
 
64. Define test plan. A test plan is developed to detect and identify potential problems before delivering the 

software to its users?  
 
65. Write the objectives of testing. Testing is the process of executing a program with the intent of finding 

errors. A good test case is the one that has a high probability of detecting an as yet undiscovered error. A 
successful test case is the one that detects an as yet undiscovered error?  

 
66. What is cyclomatic complexity? Cyclomatic complexity is software metric that provides a quantitative 

measure of the logical complexity of a program. The value computed for cyclomatic complexity defines the 
number of independent paths in the basis set of program?  

 
67. Define corollary? Corollary is a proposition that follows from an axiom or another proposition that has 

been proven?   
68. Name the two axioms.   

Axiom1: The independence axiom. Maintain the independence of components.  
Axiom2: The information axiom. Minimize the information content of the design. 

 
69. Define coupling. Coupling is a measure of the strength of association established by a connection from one 

object or software component to another. Coupling is a binary relationship. Coupling deals with interactions 
between objects or software components?  

 
70. Name the two types of coupling in the object oriented design. Interaction coupling and inheritance 

coupling?   
71. Define cohesion. Cohesion means the interactions within a single object or software component?  
 
72. Name the types of attributes. Single value attributes, Multiplicity or multivalued attributes, Reference to 

another object or instance connection?  
 
73. Write the syntax for presenting the attribute that was suggested by UML. visibility name : type_expression  

= initial _value Where visibility is one of the following   
+ public visibility  

 
# protected visibility 

private visibility   
type_expression - type of an attribute 

 
Initial_value is a language dependent expression for the initial value of a newly created 

object. 74. Write the syntax for presenting the operation that was suggested by UML 
 

visibility name : (parameter_list): return _type_expression 
Where visibility is one of the following  
+ public visibility 

 
# protected visibility 

private visibility  
parameter- is a list of parameters. 

 
Return_type_expression: is a language _dependent specification of the Implementation of the value 
returned by the method.  

75. What is a Façade? Facade classes are the public classes in a package for public behavior?  
 
76. Define DBMS? A database management system (DBMS) is a program that enables the creation and 

maintenance of a collection of related data?  
 
77. What is database model? Database model is a collection of logical constructs used to represent the data 

structure and data relationships within the database?   
78. Name the two categories of database model? Conceptual model and Implementation model?  



79. Write the six categories for the life time of data Transient results to the evaluation of expressions, variables 

involves in procedure activation, global variables and variables that are dynamically allocated, data that 

exist between the execution of a program, data that exist between the versions of a program, data that 

outlive a program?  
 
80. What is schema or metadata? The fundamental characteristic of the database is that the DBMS contains not 

only the data but the complete definition of the data formats such as data structures, types and constraints, it 
manages. This description is known as the schema or metadata?   

81. Name the three types of data base model? Hierarchical model, network model, relational model?  
 
82. Define data definition language. Data definition language (DDL) is a language used to describe the 

structure of and relationships between objects stored in a database .This structure of information are termed 
as database schema?  

 
83. Define data manipulation language. Data manipulation language (DML) is a language that allows users to 

access and manipulate (such as create, save, or destroy) data organization?  
 
84. When the transaction is said to commit. The transaction is said to commit if all changes can be made 

successfully to the database?  
 
85. When the transaction is said to abort. The transaction is said to abort if all changes to the database cannot be 

made successfully?  
 
86. What is conservative or pessimistic policy? The most conservative way to enforce serialization is to allow a 

user to lock all objects or records when they are accessed and to release the locks only after a transaction 
commits. This approach is known as conservative or pessimistic policy?  

 
87. Describe client server computing. The client is a process (program) that sends a message to a server 

process (program) requesting that the server perform a task (service)?  
 
88. Name the types of object relation mapping. Table class mapping, Table multiple classes mapping, Table-

Inherited classes mapping, Tables Inherited classes mapping?  
 
89. Write the need of middleware. The client is a process (program) that sends a message to a server process 

(program) requesting that the server perform a task (service). The key element of connectivity is the 
network operating system (NOS), also known as middleware?   

90. Mention the different forms of server. File server, database server, transaction server, application server?  
 
91. What is the use of application web server? In a two-tier architecture, a client talks directly to a server, no 

intervening server. Three tier architecture introduces a server that is application web server between the 
client and the server to send and receive the messages?   

92. Write the components of client server application. User interface, business processing, database processing?  
 
93. What is Object Oriented Database management system? Object Oriented Database management system is a 

marriage of Object Oriented programming and Database management system?  
 
94. Define ODBC? The Open Database connectivity is an application programming interface that provides 

solutions to the multi database programming interface?  
 
95. What is the need of an Interaction diagram? An Interaction diagram is used to trace the exception of a 

scenario in the same context of an object diagram?  
 
96. What is the need of a Class diagram? A class diagram is used to show the existence of classes and their 

relationships in the logical view of a system?  
 
97. What is Behavior of an object? Behavior is how an object acts and reacts in terms of its state changes 

and message passing?  
 
98. What are the characteristic features of an Interaction diagram? They include the representation of objects 

with its name and class name. Each object has a life line. The order of messaging between objects is well 
defined?   

99. Define forward engineering and revere engineering.  Forward  engineering means creating a relational  
 

Schema from an existing object model Reverse engineering means creating an object model from an 
existing relational database layout (schema)?  

 
100. What is Object request broker (ORB)? Object request broker (ORB) Middle ware that implements a 

communication channel through which applications can access object interfaces and request data and 
services?  

 
101. What is distributed database? In distributed database, different portions of the database reside on different 

nodes (computers) and disk drives in the network. Each portions of the database is managed by a server, a 
process responsible for controlling access and retrieval of data from the database portion?  

 
102. What does RAD stands for? Rapid application development (RAD) is a set of tools and techniques that can 

be used to build an application faster than typically possible with traditional methods?  



103. What are the traditional software development methodologies? Most traditional 
development methodologies are either algorithm centric or data centric? 
 


